
SỞ GIÁO DỤC VÀ ĐÀO TẠO THÀNH PHỐ HỒ CHÍ MINH
Trường THPT TRẦN QUANG KHẢI

Tổ bộ môn: TIN HỌC

Bài dạy điện tử Tin học Lớp 12

GVHD: Vũ Trường

Lớp: 12A…… – Tiết: ……

Ngày: ………………

Ví dụ: Bài toán quản lí học sinh trong Nhà trường

2

Muốn quản lí thông tin về các học
sinh trong lớp, bao gồm những
thông tin nào?

Ví dụ: Bài toán quản lí học sinh trong Nhà trường

3

Theo em, để quản lí thông tin về 
điểm của học sinh trong một lớp, 
em nên lập danh sách gồm các 
cột nào?

Ví dụ: Bài toán quản lí học sinh trong Nhà trường

4

Khi học sinh thay đổi địa chỉ,
điểm bị sai hay chuyển trường
khác thì xử lí như thế nào?

Ví dụ: Bài toán quản lí học sinh trong Nhà trường

5

Muốn chọn ra học sinh giỏi để đi
thi thì xử lí như thế nào?

Ví dụ: Bài toán quản lí học sinh trong Nhà trường

6

Cuối học kỳ và cuối năm học,
giáo viên đếm số học sinh đạt loại
giỏi thì xử lí như thế nào?
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1> Bài toán quản lí

‒ Công việc quản lí là rất phổ biến, có thể mọi tổ chức đều có nhu
cầu quản lí.

+ Ví dụ: Để quản lí học sinh, Nhà trường phải có hồ sơ học
sinh, đó là học bạ.

‒ Công việc sửa đổi được thực hiện chính xác và thường xuyên
(tốt nhất là ngay khi có thay đổi) để đảm bảo hồ sơ luôn phản
ánh đúng thực tế.

‒ Việc lập hồ sơ không chỉ đơn thuần là để lưu trữ mà chủ yếu là
để khai thác, nhằm phục vụ các yêu cầu quản lí.

+ Ví dụ: Cuối học kỳ và cuối năm học, giáo viên phải thống kê,
tổng hợp chẳng hạn: đếm số đoàn viên, số học sinh đạt loại
giỏi, tính điểm trung bình của mỗi môn học của cả lớp, …

7

2> Các công việc thường gặp khi xử lí thông tin của một
tổ chức

Hãy nêu các công việc thường gặp
khi quản lí thông tin của một tổ
chức nào đó?

‒ Tạo lập hồ sơ.
‒ Cập nhật hồ sơ.
‒ Khai thác hồ sơ.

8

2> Các công việc thường gặp khi xử lí thông tin của một
tổ chức

Mục đích cuối cùng của việc tạo
lập, cập nhật, khai thác hồ sơ là gì?

Mục đích cuối cùng của việc tạo lập,
cập nhật, khai thác hồ sơ là phục vụ, hỗ
trợ cho quá trình lập kế hoạch, ra quyết
định xử lí công việc của người có trách
nhiệm.

9

2> Các công việc thường gặp khi xử lí thông tin của một
tổ chức

‒ Tạo lập hồ sơ
+ Xác định chủ thể cần quản lí.
+ Xác định cấu trúc hồ sơ.
+ Thu thập, tập hợp thông tin cần thiết cho hồ sơ.

‒ Cập nhật hồ sơ
+ Sửa chữa hồ sơ.
+ Bổ sung thêm hồ sơ.
+ Xóa hồ sơ.

‒ Khai thác hồ sơ
+ Sắp xếp hồ sơ.
+ Tìm kiếm.
+ Thống kê.
+ Lập báo cáo.

‒ Mục đích cuối cùng của việc tạo lập, cập nhật, khai thác hồ sơ là
phục vụ, hỗ trợ cho quá trình lập kế hoạch, ra quyết định xử lí công
việc của người có trách nhiệm.

10

3> Hệ cơ sở dữ liệu

Hãy nêu khái niệm
về cơ sở dữ liệu?

11

Một CSDL (Database) là một tập hợp các dữ liệu có
liên quan với nhau, chứa thông tin của một tổ chức nào
đó (như một trường học, một ngân hàng, một công ty,
một nhà máy, …), được lưu trữ trên các thiết bị nhớ
(như băng từ, đĩa từ, USB, …) để đáp ứng nhu cầu khai
thác thông tin của nhiều người dùng với nhiều mục đích
khác nhau.

3> Hệ cơ sở dữ liệu

Hãy nêu khái niệm
về hệ quản trị cơ sở
dữ liệu?

12

Để người sử dụng có
thể tạo CSDL trên máy
tính, ta phải có một
phần mềm và phần
mềm đó được gọi là hệ
quản trị CSDL.

Phần mềm cung cấp một môi trường thuận lợi và hiệu
quả để tạo lập, lưu trữ và khai thác thông tin của CSDL
được gọi là hệ quản trị cơ sở dữ liệu (Database
Management System).
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3> Hệ cơ sở dữ liệu

Hãy kể tên các phần
mềm về hệ quản trị
cơ sở dữ liệu?

13

Để người sử dụng có
thể tạo CSDL trên máy
tính, ta phải có một
phần mềm và phần
mềm đó được gọi là hệ
quản trị CSDL.

‒ Microsoft Access
‒ MySQL
‒ Oracle
‒ SQL Server
‒ DB2
‒ …

3> Hệ cơ sở dữ liệu

Hãy nêu khái niệm
về hệ cơ sở dữ liệu?

14

Người ta thường dùng thuật ngữ hệ cơ sở dữ liệu để chỉ
một CSDL cùng với hệ quản trị CSDL quản trị và khai
thác CSDL đó.

3> Hệ cơ sở dữ liệu

Để lưu trữ và khai
thác thông tin bằng
máy tính cần phải
có những gì?

15

‒ Để lưu trữ và khai thác thông tin bằng máy tính cần 
phải có:
+ Cơ sở dữ liệu;
+ Hệ quản trị cơ sở dữ liệu;
+ Các thiết bị vật lí (máy tính, đĩa cứng, mạng, …)

3> Hệ cơ sở dữ liệu

Theo em, hệ cơ sở
dữ liệu có những
ứng dụng gì?

16

‒ Cơ sở giáo dục và đào tạo cần quản lí thông tin người học, môn học, kết quả học tập, …
‒ Cơ sở kinh doanh cần có CSDL về thông tin khách hàng, sản phẩm, việc mua bán, …
‒ Cơ sở sản xuất cần quản lí dây chuyền thiết bị và theo dõi việc sản xuất các sản phẩm trong

các nhà máy, hàng tồn kho hay trong cửa hàng và các đơn đặt hàng, …
‒ Tổ chức tài chính cần lưu thông tin về cổ phần, tình hình kinh doanh mua bán tài chính như

cổ phiếu, trái phiếu, …
‒ Cơ quan điều hành các giao dịch qua thẻ tín dụng cần quản lí việc bán hàng bằng thẻ tín

dụng và xuất ra báo cáo tài chính định kỳ (theo ngày, tuần, tháng, quí, năm, …).
‒ Ngân hàng cần quản lí các tài khoản, khoản vay, các giao dịch hằng ngày, …
‒ Hãng hàng không cần quản lí các chuyến bay, việc đăng kí vé và lịch bay, …
‒ Tổ chức viễn thông cần ghi nhận các cuộc gọi, hóa đơn hàng tháng, tính toán số dư cho các

thẻ gọi trước, …
‒ Những ứng dụng khác.

3> Hệ cơ sở dữ liệu

‒ Một cơ sở dữ liệu (Database) là một tập hợp các dữ liệu có liên quan
với nhau, chứa thông tin của một tổ chức nào đó (như một trường học,
một ngân hàng, một công ty, một nhà máy, …), được lưu trữ trên các
thiết bị nhớ (như băng từ, đĩa từ, USB, …) để đáp ứng nhu cầu khai
thác thông tin của nhiều người dùng với nhiều mục đích khác nhau.

‒ Phần mềm cung cấp một môi trường thuận lợi và hiệu quả để tạo lập,
lưu trữ và khai thác thông tin của CSDL được gọi là hệ quản trị cơ sở
dữ liệu (Database Management System).

‒ Người ta thường dùng thuật ngữ hệ cơ sở dữ liệu để chỉ một CSDL
cùng với hệ QTCSDL quản trị và khai thác CSDL đó.

‒ Để lưu trữ và khai thác thông tin bằng máy tính cần phải có:

+ Cơ sở dữ liệu;

+ Hệ quản trị cơ sở dữ liệu;

+ Các thiết bị vật lí (máy tính, đĩa cứng, mạng, …)

‒ Một số ứng dụng (xem thêm SGK15) 17

Cám ơn
quý thầy/cô đã tham dự

Thân ái
chào các em

18
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SỞ GIÁO DỤC VÀ ĐÀO TẠO THÀNH PHỐ HỒ CHÍ MINH
Trường THPT TRẦN QUANG KHẢI

Tổ bộ môn: TIN HỌC

Bài dạy điện tử Tin học Lớp 12

GVHD: Vũ Trường

Lớp: 12A…… – Tiết: ……

Ngày: ………………

Ví dụ: Các kiểu dữ liệu dùng trong chương trình

2

Để khai báo biến i, j là kiểu số
nguyên, k là số thực để dùng
trong chương trình, em làm như
thế nào?

Ở lớp 11, chúng ta đã được học về ngôn ngữ lập trình và
minh họa bằng ngôn ngữ lập trình Free Pascal.

Var
i, j : integer ;
k : real ;

Ví dụ: Các kiểu dữ liệu dùng trong chương trình

3

Để nhập được Họ tên vào chương
trình, thì biến hoten được khai
báo như thế nào?

Ở lớp 11, chúng ta đã được học về ngôn ngữ lập trình và
minh họa bằng ngôn ngữ lập trình Free Pascal.

Var
hoten : string;

Ví dụ: Các kiểu dữ liệu dùng trong chương trình

4

 Thực chất đây cũng là khai báo kiểu dữ liệu.
 Hệ quản trị cơ sở dữ liệu cũng cho phép sử dụng ngôn

ngữ định nghĩa dữ liệu để khai báo kiểu dữ liệu.

1> Các chức năng của hệ quản trị cơ sở dữ liệu

5

Hãy trình bày các chức năng của
hệ quản trị cơ sở dữ liệu?

‒ Cung cấp môi trường tạo lập CSDL.
‒ Cung cấp môi trường cập nhật và khai thác dữ

liệu.
‒ Cung cấp công cụ kiểm soát, điều khiển truy

cập vào CSDL.

1> Các chức năng của hệ quản trị cơ sở dữ liệu

6

Ngôn ngữ định nghĩa dữ liệu
dùng để làm gì?

‒ Ngôn ngữ định nghĩa dữ liệu dùng để:
+ Khai báo kiểu dữ liệu.
+ Khai báo cấu trúc dữ liệu.
+ Khai báo các ràng buộc trên dữ liệu.
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1> Các chức năng của hệ quản trị cơ sở dữ liệu

7

Ngôn ngữ thao tác dữ liệu dùng
để làm gì?

‒ Ngôn ngữ thao tác dữ liệu dùng để diễn tả
yêu cầu cập nhật hay khai thác thông tin.

1> Các chức năng của hệ quản trị cơ sở dữ liệu

8

Cập nhật dữ liệu bao gồm những
công việc gì?

‒ Nhập dữ liệu.
‒ Sửa dữ liệu,
‒ Xóa dữ liệu;

1> Các chức năng của hệ quản trị cơ sở dữ liệu

9

Khai thác dữ liệu bao gồm
những công việc gì?

‒ Sắp xếp.
‒ Tìm kiếm
‒ Kết xuất báo cáo.
‒ ……

1> Các chức năng của hệ quản trị cơ sở dữ liệu

10

Ngôn ngữ điều khiển dữ liệu
dùng để làm gì?

‒ Ngôn ngữ điều khiển dữ liệu dùng để xác lập
quyền truy cập vào cơ sở dữ liệu.

1> Các chức năng của hệ quản trị cơ sở dữ liệu

‒ Cung cấp môi trường tạo lập CSDL

+ Một hệ QTCSDL phải cung cấp một môi trường cho người dùng dễ dàng khai báo
kiểu dữ liệu, các cấu trúc dữ liệu thể hiện thông tin và các ràng buộc trên dữ liệu
thông qua ngôn ngữ định nghĩa dữ liệu.

+ Ngôn ngữ định nghĩa dữ liệu thực chất là hệ thống các kí hiệu để mô tả CSDL.

‒ Cung cấp môi trường cập nhật và khai thác dữ liệu

+ Ngôn ngữ để người dùng diễn tả yêu cầu cập nhật hay khai thác thông tin được
gọi là ngôn ngữ thao tác dữ liệu.

+ Thao tác dữ liệu gồm:

o Cập nhật (nhập, sửa, xóa dữ liệu);

o Khai thác (sắp xếp, tìm kiếm, kết xuất báo cáo, …).

‒ Chú ý:

+ Trong thực tế, ngôn ngữ dùng để định nghĩa và thao tác dữ liệu là hai thành phần
của một ngôn ngữ CSDL duy nhất.

+ Ngôn ngữ CSDL được sử dụng phổ biến hiện nay là SQL (Structured Query
Language – ngôn ngữ hỏi có cấu trúc).

11

1> Các chức năng của hệ quản trị cơ sở dữ liệu

‒ Cung cấp công cụ kiểm soát, điều khiển truy cập vào CSDL

+ Hệ QTCSDL thực hiện được chức năng này phải có các bộ
chương trình thực hiện những nhiệm sau:

oPhát hiện và ngăn chặn sự truy cập không được phép;

oDuy trì tính nhất quán của dữ liệu;

oTổ chức và điều khiển các truy cập đồng thời;

oKhôi phục CSDL khi có sự cố ở phần cứng hay phần
mềm;

oQuản lí các mô tả dữ liệu.

12
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2> Vai trò của con người khi làm việc với hệ CSDL

13

Hãy kể tên các vai trò của con
người khi làm việc với hệ CSDL?

‒ Người quản trị cơ sở dữ liệu.
‒ Người lập trình ứng dụng.
‒ Người dùng.

2> Vai trò của con người khi làm việc với hệ CSDL

14

Hãy trình bày hiểu biết của em về
người quản trị cơ sở dữ liệu?

Người quản trị cơ sở dữ liệu là một người, hay
một nhóm người được trao quyền điều hành hệ
CSDL.

2> Vai trò của con người khi làm việc với hệ CSDL

15

Hãy trình bày hiểu biết của em về
người lập trình ứng dụng?

Khi CSDL đã được cài đặt, cần có các chương
trình ứng dụng đáp ứng nhu cầu khai thác của các
nhóm người dùng. Đây chính là công việc của
người lập trình ứng dụng.

2> Vai trò của con người khi làm việc với hệ CSDL

16

Hãy trình bày hiểu biết của em về
người dùng?

Người dùng (hay còn gọi là người dùng đầu
cuối): chính là người có nhu cầu khai thác thông
tin từ CSDL. Họ tương tác với các hệ thống
thông qua việc sử dụng một chương trình ứng
dụng đã được viết trước.

2> Vai trò của con người khi làm việc với hệ CSDL

‒ Người quản trị cơ sở dữ liệu: là một người, hay một nhóm
người được trao quyền điều hành hệ CSDL.

‒ Người lập trình ứng dụng: Khi CSDL đã được cài đặt, cần có
các chương trình ứng dụng đáp ứng nhu cầu khai thác của các
nhóm người dùng. Đây chính là công việc của người lập trình
ứng dụng.

‒ Người dùng (hay còn gọi là người dùng đầu cuối): chính là
người có nhu cầu khai thác thông tin từ CSDL. Họ tương tác với
các hệ thống thông qua việc sử dụng một chương trình ứng dụng
đã được viết trước.

17

3> Các bước xây dựng cơ sở dữ liệu

18

Hãy trình bày các bước xây dựng
cơ sở dữ liệu?

‒ Bước 1: Khảo sát.
‒ Bước 2: Thiết kế.
‒ Bước 3: Kiểm thử.
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3> Các bước xây dựng cơ sở dữ liệu

19

Khảo sát bao gồm những công
việc gì?

‒ Tìm hiểu các yêu cầu của công tác quản lí.
‒ Xác định các dữ liệu cần lưu trữ, phân tích mối

liên hệ giữa chúng;
‒ Phân tích các chức năng cần có của hệ thống

khai thác thông tin, đáp ứng các yêu cầu đặt ra.
‒ Xác định khả năng phần cứng, phần mềm có thể

khai thác, sử dụng.

3> Các bước xây dựng cơ sở dữ liệu

20

Thiết kế bao gồm những công
việc gì?

‒ Thiết kế CSDL;
‒ Lựa chọn hệ quản trị CSDL để triển khai;
‒ Xây dựng hệ thống chương trình ứng dụng.

3> Các bước xây dựng cơ sở dữ liệu

21

Kiểm thử bao gồm những công
việc gì?

‒ Nhập dữ liệu cho CSDL.
‒ Tiến hành chạy thử các chương trình ứng dụng.

3> Các bước xây dựng cơ sở dữ liệu

‒ Bước 1: Khảo sát
+ Tìm hiểu các yêu cầu của công tác quản lí.
+ Xác định các dữ liệu cần lưu trữ, phân tích mối liên hệ giữa chúng;
+ Phân tích các chức năng cần có của hệ thống khai thác thông tin,

đáp ứng các yêu cầu đặt ra.
+ Xác định khả năng phần cứng, phần mềm có thể khai thác, sử

dụng.
‒ Bước 2: Thiết kế

+ Thiết kế CSDL;
+ Lựa chọn hệ QTCSDL để triển khai;
+ Xây dựng hệ thống chương trình ứng dụng

‒ Bước 3: Kiểm thử
+ Nhập dữ liệu cho CSDL;
+ Tiến hành chạy thử các chương trình ứng dụng.

22

23

Cám ơn
quý thầy/cô đã tham dự

Thân ái
chào các em
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SỞ GIÁO DỤC VÀ ĐÀO TẠO THÀNH PHỐ HỒ CHÍ MINH
Trường THPT TRẦN QUANG KHẢI

Tổ bộ môn: TIN HỌC

Bài dạy điện tử Tin học Lớp 12

GVHD: Vũ Trường

Lớp: 12A…… – Tiết: ……

Ngày: ………………

Ví dụ: Bài toán quản lý học sinh

2

Muốn lưu thông tin về quản lí
học sinh thì xử lý như thế nào?

Ví dụ: Bài toán quản lý học sinh

3

Muốn lưu thông tin với thời gian
ngắn nhất, chính xác nhất và lâu
dài thì xử lý như thế nào?

Giải pháp tốt nhất là chọn dùng cơ sở dữ liệu
Access để quản lý, xử lý dữ liệu và lưu trữ dữ
liệu lâu dài thay cho việc quản lý bằng giấy.

4

Ví dụ: Bài toán quản lý học sinh

1> Hệ quản trị cơ sở dữ liệu Microsoft Access

Em biết gì về phần mềm
Microsoft Access?

Phần mềm Microsoft Access (gọi tắt là
Access) là hệ quản trị cơ sở dữ liệu nằm
trong bộ phần mềm Microsoft Office
của hãng Microsoft dành cho máy tính
cá nhân và máy tính chạy trong mạng
cục bộ.

5

1> Hệ quản trị cơ sở dữ liệu Microsoft Access

Phần mềm Microsoft
Access có bản quyền hay
không, thuộc công ty nào?

Phần mềm Microsoft Access là phần
mềm có bản quyền và thuộc hãng
Microsoft.

6
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1> Hệ quản trị cơ sở dữ liệu Microsoft Access

Chức năng của Access là
gì?

‒ Tạo lập các cơ sở dữ liệu và lưu trữ
chúng trên các thiết bị nhớ.

‒ Tạo biểu mẫu để cập nhật dữ liệu,
tạo báo cáo thống kê, tổng kết hay
những mẫu hỏi để khai thác dữ liệu
trong CSDL, giải quyết các bài toán
quản lí.

7

1> Hệ quản trị cơ sở dữ liệu Microsoft Access

‒ Phần mềm Microsoft Access (gọi tắt là Access) là hệ quản trị cơ
sở dữ liệu nằm trong bộ phần mềm Microsoft Office của hãng
Microsoft dành cho máy tính cá nhân và máy tính chạy trong
mạng cục bộ.

8

a) Giới thiệu Microsoft Access

‒ Tạo lập các cơ sở dữ liệu và lưu trữ chúng trên các thiết bị nhớ.

‒ Tạo biểu mẫu để cập nhật dữ liệu, tạo báo cáo thống kê, tổng kết
hay những mẫu hỏi để khai thác dữ liệu trong CSDL, giải quyết
các bài toán quản lí.

b) Chức năng của Microsoft Access

2> Một số thao tác cơ bản

Tùy theo phiên bản Windows, Office mà
có cách khởi động khác nhau.

9

‒ Cách 1: Từ bảng chọn Windows Start: nháy chuột Start/ (All)
Programs/ Microsoft Office/ Microsoft Access 2010.

‒ Cách 2: Từ biểu tượng shortcut của Access: double click vào
biểu tượng trên màn hình Desktop (nếu có).

a) Khởi động Microsoft Access

10

2> Một số thao tác cơ bản

b) Giới thiệu màn hình làm việc

Thanh Ribbon: chứa các biểu tượng (icon) đại diện cho một hành động
nào đó mà khi người sử dụng nhấn vào thì nó sẽ thực hiện. Vùng hiển
thị của thanh công cụ trong những phiên bản Microsoft Access trước
đây sẽ được dùng để hiển thị thanh Ribbon trong phiên bản Microsoft
Access 2010. Ứng với mỗi đối tượng mà chúng ta làm việc, thanh
Ribbon sẽ tự động thay đổi cho phù hợp với đối tượng tương ứng.

11

2> Một số thao tác cơ bản

c) Tạo cơ sở dữ liệu mới

‒ Bước 1: Khởi động Access 2010.

12

2> Một số thao tác cơ bản

c) Tạo cơ sở dữ liệu mới

‒ Bước 2: Click File => New => Blank database. Nhập tên cần
đặt vào ô File Name. Click vào biểu tượng bên cạnh ô File
Name để chọn thư mục lưu cơ sở dữ liệu.
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13

2> Một số thao tác cơ bản

c) Tạo cơ sở dữ liệu mới

‒ Bước 3: Xuất hiện một hộp thoại, chọn thư mục lưu cơ sở dữ
liệu, sau đó click OK.

14

2> Một số thao tác cơ bản

c) Tạo cơ sở dữ liệu mới

‒ Bước 4: Click biểu tượng Create.

15

2> Một số thao tác cơ bản

c) Tạo cơ sở dữ liệu mới

‒ Cơ sở dữ liệu sau khi đã tạo xong.

16

2> Một số thao tác cơ bản

d) Các đối tượng chính của Access

‒ Bảng (Tables): dùng để lưu dữ liệu. Mỗi bảng
chứa thông tin về một chủ thể xác định và bao
gồm nhiều hàng, mỗi hàng chứa các thông tin
về một cá thể xác định của chủ thể đó.

‒ Mẫu hỏi (Queries): dùng để sắp xếp, tìm
kiếm và kết xuất dữ liệu xác định từ một hoặc
nhiều bảng.

‒ Biểu mẫu (Forms): giúp tạo giao diện thuận
tiện cho việc nhập hoặc hiển thị thông tin.

‒ Báo cáo (Reports): được thiết kế để định
dạng, tính toán, tổng hợp các dữ liệu được
chọn và in ra.

17

2> Một số thao tác cơ bản

e) Mở cơ sở dữ liệu đã có

‒ Cách 1: Double click vào tên CSDL muốn mở.

‒ Cách 2: Click chuột vào tên của CSDL (nếu có trong cửa sổ
File).

‒ Cách 3: Chọn lệnh File => Open rồi tìm CSDL muốn mở lên.
Chọn Open.

18

2> Một số thao tác cơ bản

f) Kết thúc phiên làm việc

‒ Cách 1: Chọn File => Exit.
‒ Cách 2: Nháy nút X ở góc trên bên phải màn hình làm việc của

Access.
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2> Một số thao tác cơ bản

‒ Cách 1: Từ bảng chọn Windows Start: nháy chuột Start/ (All)
Programs/ Microsoft Office/ Microsoft Access 2010.

‒ Cách 2: Từ biểu tượng shortcut của Access: double click vào
biểu tượng trên màn hình Desktop (nếu có).

b) Giới thiệu màn hình làm việc

‒ Thanh Ribbon: chứa các biểu tượng (icon) đại diện cho một
hành động nào đó mà khi người sử dụng nhấn vào thì nó sẽ
thực hiện. Vùng hiển thị của thanh công cụ trong những phiên
bản Microsoft Access trước đây sẽ được dùng để hiển thị thanh
Ribbon trong phiên bản Microsoft Access 2010. Ứng với mỗi
đối tượng mà chúng ta làm việc, thanh Ribbon sẽ tự động thay
đổi cho phù hợp với đối tượng tương ứng.

a) Khởi động Microsoft Access

20

2> Một số thao tác cơ bản

‒ Bước 1: Khởi động Access 2010.
‒ Bước 2: Click File => New => Blank database. Nhập tên cần đặt vào ô

File Name. Click vào biểu tượng bên cạnh ô File Name để chọn thư mục
lưu cơ sở dữ liệu.

‒ Bước 3: Xuất hiện một hộp thoại, chọn thư mục lưu cơ sở dữ liệu, sau đó
click OK.

‒ Bước 4: Click biểu tượng Create.

c) Tạo cơ sở dữ liệu mới

‒ Bảng (Tables): dùng để lưu dữ liệu. Mỗi bảng chứa thông tin về một chủ
thể xác định và bao gồm nhiều hàng, mỗi hàng chứa các thông tin về một
cá thể xác định của chủ thể đó.

‒ Mẫu hỏi (Queries): dùng để sắp xếp, tìm kiếm và kết xuất dữ liệu xác định
từ một hoặc nhiều bảng.

‒ Biểu mẫu (Forms): giúp tạo giao diện thuận tiện cho việc nhập hoặc hiển
thị thông tin.

‒ Báo cáo (Reports): được thiết kế để định dạng, tính toán, tổng hợp các dữ
liệu được chọn và in ra.

d) Các đối tượng chính của Access

21

2> Một số thao tác cơ bản

e) Mở cơ sở dữ liệu đã có

‒ Cách 1: Double click vào tên CSDL muốn mở.

‒ Cách 2: Click chuột vào tên của CSDL (nếu có trong cửa sổ File).

‒ Cách 3: Chọn lệnh File => Open rồi tìm CSDL muốn mở lên. Chọn Open.

f) Kết thúc phiên làm việc

‒ Cách 1: Chọn File => Exit.

‒ Cách 2: Nháy nút X ở góc trên bên phải màn hình làm việc của Access.

22

Cám ơn
quý thầy/cô đã tham dự

Thân ái
chào các em
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SỞ GIÁO DỤC VÀ ĐÀO TẠO THÀNH PHỐ HỒ CHÍ MINH
Trường THPT TRẦN QUANG KHẢI

Tổ bộ môn: TIN HỌC

Bài dạy điện tử Tin học Lớp 12

GVHD: Vũ Trường

Lớp: 12A…… – Tiết: ……

Ngày: ……………... 

Ví dụ: Bài toán quản lý học sinh

2

Hình ảnh trên có những thông
tin gì?

Ví dụ: Bài toán quản lý học sinh

3

Các thông tin trên được bố trí
như thế nào?

Ví dụ: Bài toán quản lý học sinh

4

Các cột và các hàng này tạo
thành gì?

Ví dụ: Bài toán quản lý học sinh

5

Nếu lưu các thông tin này trong
máy tính thì lưu dưới dạng gì?

Ví dụ: Bài toán quản lý học sinh

6

Các thông tin được lưu trong máy tính gọi là
dữ liệu, dữ liệu trong Access được lưu dưới
dạng bảng.
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1> Các khái niệm chính

7

Em hãy cho biết
bảng là gì?

Bảng (Table): gồm các cột và các hàng,
bảng là thành phần cơ sở tạo nên CSDL.
Các bảng chứa toàn bộ dữ liệu mà người
dùng cần để khai thác. Bao gồm 2 thành
phần đó là “hàng” và “cột”.

1> Các khái niệm chính

Em hãy cho biết
trường của bảng
là gì?

Trường (field): mỗi trường là một cột của 
bảng thể hiện một thuộc tính của chủ thể 
cần quản lý.

8

Mỗi cột trong bảng dùng
để lưu dữ liệu một thuộc
tính của các cá thể. Mỗi
cột gọi là một trường của
bảng.

1> Các khái niệm chính

Em hãy cho biết
bản ghi là gì?

9

Mỗi hàng của bảng dùng
để lưu dữ liệu của một
HS. Người ta gọi mỗi
hàng là một bản ghi của
bảng.

Bản ghi (record): mỗi bản ghi là một hàng
của bảng gồm dữ liệu về các thuộc tính của
chủ thể được quản lý.

1> Các khái niệm chính

Em có nhận xét
gì về dữ liệu
của bảng nằm
trên một cột?

10

Như vậy, dữ liệu trong Access được
lưu trữ dưới dạng các bảng, gồm có
các cột (trường – field) và các hàng
(bản ghi – record). Một bảng là tập
hợp dữ liệu về một chủ thể nào đó,
chẳng hạn tập hợp HS của một lớp
hoặc tập hợp hóa đơn bán hàng, …

Trong một cột, các dữ
liệu có chung một
kiểu.

1> Các khái niệm chính

Kiểu dữ liệu là 
gì?

11

Kiểu dữ liệu (Data
Type): là kiểu của dữ
liệu lưu trong một
trường. Mỗi trường có
một kiểu dữ liệu.

Kiểu

dữ liệu
Mô tả

Kích thước

lưu trữ

Text
Dữ liệu kiểu văn bản gồm

các kí tự
0-255 kí tự

Number Dữ liệu kiểu số
1, 2, 4

hoặc 8 byte

Date/Time Dữ liệu kiểu ngày/giờ 8 byte

Currency Dữ liệu kiểu tiền tệ 8 byte

AutoNumber

Dữ liệu kiểu số đếm, tăng tự

động cho bản ghi mới và

thường có bước tăng là 1

4 hoặc

16 byte

Yes/No
Dữ liệu kiểu Boolean (hay

lôgic)
1 bit

Memo Dữ liệu kiểu văn bản
0-65536

kí tự

1> Các khái niệm chính

‒ Bảng (Table): gồm các cột và các hàng, bảng là thành phần cơ
sở tạo nên CSDL. Các bảng chứa toàn bộ dữ liệu mà người
dùng cần để khai thác. Bao gồm 2 thành phần đó là “hàng” và
“cột”.

‒ Trường (field): mỗi trường là một cột của bảng thể hiện một
thuộc tính của chủ thể cần quản lí.

‒ Bản ghi (record): mỗi bản ghi là một hàng của bảng gồm dữ
liệu về các thuộc tính của chủ thể được quản lí.

‒ Kiểu dữ liệu (Data Type): là kiểu của dữ liệu lưu trong một
trường. Mỗi trường có một kiểu dữ liệu.

12
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2> Tạo và sửa cấu trúc bảng

‒ Cách 1: Create => Table Design.

‒ Cách 2: Create => Table. Sau đó, click phải tên bảng vừa tạo,
chọn Design View, đặt tên cho bảng rồi OK.

(Thường sử dụng cách 1)

a) Tạo cấu trúc bảng

14

2> Tạo và sửa cấu trúc bảng

‒ Cửa sổ cấu trúc bảng được chia làm 2 khung:
+ Khung trên: phần định nghĩa trường.
+ Khung dưới: phần các tính chất của trường (H.22 – SGK35)

‒ Gõ tên trường vào cột
Field Name.

‒ Chọn kiểu dữ liệu trong
cột Data Type.

‒ Mô tả nội dung trường
trong cột Description
(phần này không nhất
thiết phải có).

‒ Lựa chọn tính chất của
trường trong phần Field
Properties.

a) Tạo cấu trúc bảng

2> Tạo và sửa cấu trúc bảng

‒ Chỉ định khóa chính

+ Bước 1: Chọn trường làm khóa chính.

+ Bước 2: Click nút lệnh Primary Key (Design => Primary
Key) hoặc click phải chọn Primary Key.

‒ Access hiển thị chiếc chìa khóa ở bên trái trường đã chọn để cho
biết trường đó được chỉ định là khóa chính.

15

2> Tạo và sửa cấu trúc bảng

‒ Lưu cấu trúc bảng

+ Bước 1: Chọn File => Save hoặc click phải chọn Save.

+ Bước 2: Gõ tên bảng vào ô Table Name trong hộp thoại
Save As.

+ Bước 3: Click OK hoặc nhấn Enter.

16

‒ Để thay đổi cấu trúc bảng. ta hiển thị bảng ở chế độ thiết kế.
‒ Thay đổi thứ tự các trường:

+ Chọn trường muốn thay đổi vị trí, nhấn chuột và giữ.
+ Di chuyển chuột, đường nằm ngang đó sẽ cho biết vị trí mới của trường.
+ Thả chuột khi đã di chuyển trường đến vị trí mong muốn.

‒ Thêm trường:
+ Click nút Insert Rows
+ Gõ tên trường, chọn kiểu dữ liệu, mô tả và xác định các tính chất của trường

(nếu có).
‒ Xóa trường:

+ Chọn trường muốn xóa.
+ Click nút Delete Rows

‒ Thay đổi khóa chính:
+ Chọn trường muốn chỉ định làm khóa chính.
+ Click nút Primary Key

17

2> Tạo và sửa cấu trúc bảng

b) Thay đổi cấu trúc bảng

18

2> Tạo và sửa cấu trúc bảng

c) Xóa và đổi tên bảng

‒ Xóa bảng:

+ Chọn tên bảng trong trang bảng.

+ Nhấn phím Delete (Del) hoặc click
nút lệnh Delete.

‒ Đổi tên bảng:

+ Click phải bảng và chọn Rename.

+ Khi tên bảng có viền khung là đường
liền nét. Click chuột vào trong phần
tên bảng để gõ tên bảng mới, rồi nhấn
Enter.
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2> Tạo và sửa cấu trúc bảng

‒ Tạo cấu trúc bảng:

+ Cách 1: Create => Table Design. (Thường sử dụng)

+ Cách 2: Create => Table. Sau đó, click phải tên bảng vừa tạo, chọn Design View, đặt tên cho
bảng rồi OK.

‒ Cửa sổ của cấu trúc bảng gồm 2 khung:

+ Khung trên (phần định nghĩa trường):

o Gõ tên trường vào cột Field Name.

o Chọn kiểu dữ liệu trong cột Data Type.

o Mô tả nội dung trường trong cột Description (phần này không nhất thiết phải có).

+ Khung dưới (tính chất của trường – Field Properties): nhập tính chất của trường (nếu có).

‒ Chỉ định khóa chính:

+ Bước 1: Chọn trường làm khóa chính.

+ Bước 2: Click nút lệnh Primary Key (Design => Primary Key) hoặc click phải chọn
Primary Key.

‒ Lưu cấu trúc bảng:

+ Bước 1: Chọn File => Save hoặc click phải chọn Save.

+ Bước 2: Gõ tên bảng vào ô Table Name trong hộp thoại Save As.

+ Bước 3: Click OK hoặc nhấn Enter.

a) Tạo cấu trúc bảng

20

2> Tạo và sửa cấu trúc bảng
b) Thay đổi cấu trúc bảng

‒ Để thay đổi cấu trúc bảng, ta hiển thị bảng ở chế độ thiết kế.

‒ Thay đổi thứ tự các trường:

+ Chọn trường muốn thay đổi vị trí, nhấn chuột và giữ.

+ Di chuyển chuột, đường nằm ngang đó sẽ cho biết vị trí mới của trường.

+ Thả chuột khi đã di chuyển trường đến vị trí mong muốn.

‒ Thêm trường:

+ Click nút Insert Rows

+ Gõ tên trường, chọn kiểu dữ liệu, mô tả và xác định các tính chất của trường (nếu
có).

‒ Xóa trường:

+ Chọn trường muốn xóa.

+ Click nút Delete Rows

‒ Thay đổi khóa chính:

+ Chọn trường muốn chỉ định làm khóa chính.

+ Click nút Primary Key

21

2> Tạo và sửa cấu trúc bảng
c) Xóa và đổi tên bảng

‒ Xóa bảng:

+ Chọn tên bảng trong trang bảng.

+ Nhấn phím Delete (Del) hoặc click nút lệnh Delete.

‒ Đổi tên bảng:

+ Click phải bảng và chọn Rename.

+ Khi tên bảng có viền khung là đường liền nét. Click chuột vào trong phần tên bảng
để gõ tên bảng mới, rồi nhấn Enter.

22
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SỞ GIÁO DỤC VÀ ĐÀO TẠO THÀNH PHỐ HỒ CHÍ MINH
Trường THPT TRẦN QUANG KHẢI

Tổ bộ môn: TIN HỌC

Bài dạy điện tử Tin học Lớp 12

GVHD: Vũ Trường

Lớp: 12A…… – Tiết: ……

Ngày: ………………

Ví dụ: CSDL QuanLi_HS (BTTH3 – SGK48)

Khi nhập thông tin sai như: Họ
tên, giới tính, ngày sinh, … thì
xử lý như thế nào?

2

Trong trường hợp, danh sách
không có tên mình nhưng mình
lại học tại lớp này thì phải làm
như thế nào?

Ví dụ: CSDL QuanLi_HS (BTTH3 – SGK48)

3

Trong trường hợp, danh sách có
tên HS nhưng HS đó lại học ở lớp
khác thì xử lý như thế nào?

Ví dụ: CSDL QuanLi_HS (BTTH3 – SGK48)

4

Ví dụ: CSDL QuanLi_HS (BTTH3 – SGK48)

Thao tác chỉnh sửa, thêm, xóa chính là
công việc cập nhật dữ liệu trong bảng.

5

1> Cập nhật dữ liệu

Em hiểu thế nào là
cập nhật CSDL?

Cập nhật CSDL là thay đổi dữ liệu

trong các bảng gồm: thêm bản ghi mới,

chỉnh sửa, xóa các bản ghi.

6
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1> Cập nhật dữ liệu

‒ Cách 1: Nhập dữ liệu vào hàng cuối cùng, tương ứng trong mỗi
trường.

‒ Cách 2: Click nút New (blank) record, rồi nhập dữ liệu tương
ứng trong mỗi trường.

‒ Cách 3: Click phải, chọn New Record.

a) Thêm bản ghi mới

Nếu thêm hoặc thay đổi giá trị của một
bản ghi thì dữ liệu được lưu tự động mỗi
khi chuyển tới bản ghi khác. 7

1> Cập nhật dữ liệu

‒ Để chỉnh sửa giá trị một trường của một bản ghi chỉ cần click
chuột vào ô chứa dữ liệu tương ứng và thực hiện các thay đổi
cần thiết.

b) Chỉnh sửa

8

1> Cập nhật dữ liệu

‒ Bước 1: Chọn bản ghi cần xóa.
‒ Bước 2: Nhấn phím Delete hoặc click biểu tượng Delete (hoặc

click phải chọn Delete Record)
‒ Bước 3: Trong hộp thoại khẳng định xóa, chọn Yes.

c) Xóa bản ghi

9

1> Cập nhật dữ liệu

‒ Bước 1: Chọn bản ghi cần xóa.
‒ Bước 2: Nhấn phím Delete hoặc click biểu tượng Delete (hoặc click phải

chọn Delete Record)
‒ Bước 3: Trong hộp thoại khẳng định xóa, chọn Yes.

c) Xóa bản ghi

‒ Để chỉnh sửa giá trị một trường của một bản ghi chỉ cần click chuột vào
ô chứa dữ liệu tương ứng và thực hiện các thay đổi cần thiết.

b) Chỉnh sửa

‒ Cách 1: Nhập dữ liệu vào hàng cuối cùng, tương ứng trong mỗi trường.
‒ Cách 2: Click nút New (blank) record, rồi nhập dữ liệu tương ứng

trong mỗi trường.
‒ Cách 3: Click phải, chọn New Record.

a) Thêm bản ghi mới

‒ Cập nhật CSDL là thay đổi dữ liệu trong các bảng gồm: thêm bản ghi

mới, chỉnh sửa, xóa các bản ghi.

10

2> Sắp xếp và lọc

‒ Bước 1: Chọn trường cần sắp xếp trong chế độ hiển thị trang dữ
liệu;

‒ Bước 2: Dùng các nút lệnh tăng dần, giảm dần để sắp xếp các
bản ghi của bảng dựa trên giá trị của trường được chọn;

‒ Bước 3: Lưu lại kết quả sắp xếp.

(Nếu muốn trở về trạng thái ban đầu thì click Remove Sort)

a) Sắp xếp

11

2> Sắp xếp và lọc

‒ Lọc là một công cụ của hệ QTCSDL cho phép tìm ra những bản
ghi thỏa mãn một số điều kiện nào đó phục vụ tìm kiếm.

‒ Bước 1: Chọn trường (cột), click Filter.

‒ Bước 2: Chọn điều kiện lọc, rồi click OK.

(Muốn trở về trạng thái ban đầu thì click Toggle Filter). 

b) Lọc

12
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2> Sắp xếp và lọc

‒ Bước 1: Chọn trường cần sắp xếp trong chế độ hiển thị trang
dữ liệu;

‒ Bước 2: Dùng các nút lệnh tăng dần, giảm dần để sắp xếp các
bản ghi của bảng dựa trên giá trị của trường được chọn;

‒ Bước 3: Lưu lại kết quả sắp xếp.
(Nếu muốn trở về trạng thái ban đầu thì click Remove Sort)

a) Sắp xếp

‒ Lọc là một công cụ của hệ QTCSDL cho phép tìm ra những
bản ghi thỏa mãn một số điều kiện nào đó phục vụ tìm kiếm.

‒ Bước 1: Chọn trường (cột), click Filter.

‒ Bước 2: Chọn điều kiện lọc, rồi click OK.

(Muốn trở về trạng thái ban đầu thì click Toggle Filter).

b) Lọc

13

3> Tìm kiếm đơn giản

‒ Chức năng tìm kiếm (tìm kiếm và thay thế) trong
Access tương tự như chức năng này trong Word.

4> In dữ liệu

‒ Có thể in dữ liệu từ bảng.

‒ Việc thiết đặt trang in và xem trước khi in thực
hiện tương tự như trong Word.

14

15
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SỞ GIÁO DỤC VÀ ĐÀO TẠO THÀNH PHỐ HỒ CHÍ MINH
Trường THPT TRẦN QUANG KHẢI

Tổ bộ môn: TIN HỌC

Bài dạy điện tử Tin học Lớp 12

GVHD: Vũ Trường

Lớp: 12A…… – Tiết: ……

Ngày: ………………

Bảng: BANGDIEM_HOC_SINH

Tên trường Mô tả Ghi chú

MAHS Mã học sinh

MALOP Mã lớp học

HOHS Họ tên học sinh

TENHS Tên học sinh

PHAI Phái học sinh

NGAYSINH Ngày sinh học sinh

GVCN Tên giáo viên chủ nhiệm.

PHONGHOC Phòng học

HOCKY Học kỳ: 1, 2

TOAN Điểm Toán

LY Điểm Lý

HOA Điểm Hóa

SINH Điểm Sinh

VAN Điểm Văn

DTB Điểm trung bình

XEPLOAI Xếp loại

Khi lập CSDL với 1 bảng
duy nhất, dữ liệu nhập vào
sẽ xảy ra trường hợp gì?

Dữ liệu có thể bị 
trùng lặp, nhầm 
lẫn khi nhập, …

Cách thứ nhất: Lập CSDL với một bảng duy nhất chứa tất cả các thông tin cần 
thiết chia thành các trường sau:

Ví dụ: CSDL Quản lí điểm học sinh.

Chia một bảng thành
nhiều bảng.

2

Cách thứ hai: Lập CSDL gồm 3 bảng có cấu trúc tương
tự như sau:

Bảng: HOCSINH

Tên trường Mô tả Ghi chú

MAHS Mã học sinh Khóa chính

MALOP Mã lớp học

HOHS Họ tên học sinh

TENHS Tên học sinh

PHAI Phái học sinh

NGAYSINH Ngày sinh học sinh

Bảng: LOPHOC
Tên trường Mô tả Ghi chú

MALOP Mã lớp học Khóa chính
GVCN Tên giáo viên chủ nhiệm.
PHONGHOC Phòng học

Bảng: DIEM
Tên trường Mô tả Ghi chú
HOCKY Học kỳ: 1, 2 Khóa chính
MAHS Mã học sinh Khóa chính
TOAN Điểm Toán
LY Điểm Lý
HOA Điểm Hóa
SINH Điểm Sinh
VAN Điểm Văn
DTB Điểm trung bình
XEPLOAI Xếp loại

Khi lập CSDL với 3 bảng,
dữ liệu nhập vào sẽ như thế
nào?

Dữ liệu không bị
trùng lặp, nhầm lẫn
khi nhập, …

Cách thứ hai khắc phục
được những nhược điểm
của cách thứ nhất.

3

Ví dụ: CSDL Quản lí điểm học sinh.

Bảng: BANGDIEM_HOC_SINH

Tên trường Mô tả Ghi chú

MAHS Mã học sinh

MALOP Mã lớp học

HOHS Họ tên học sinh

TENHS Tên học sinh

PHAI Phái học sinh

NGAYSINH Ngày sinh học sinh

GVCN Tên giáo viên chủ nhiệm.

PHONGHOC Phòng học

HOCKY Học kỳ: 1, 2

TOAN Điểm Toán

LY Điểm Lý

HOA Điểm Hóa

SINH Điểm Sinh

VAN Điểm Văn

DTB Điểm trung bình

XEPLOAI Xếp loại

Bảng: HOCSINH

Tên trường Mô tả Ghi chú

MAHS Mã học sinh Khóa chính

MALOP Mã lớp học

HOHS Họ tên học sinh

TENHS Tên học sinh

PHAI Phái học sinh

NGAYSINH Ngày sinh học sinh

Bảng: LOPHOC
Tên trường Mô tả Ghi chú

MALOP Mã lớp học Khóa chính
GVCN Tên giáo viên chủ nhiệm.
PHONGHOC Phòng học

Bảng: DIEM
Tên trường Mô tả Ghi chú

HOCKY Học kỳ: 1, 2 Khóa chính
MAHS Mã học sinh Khóa chính
TOAN Điểm Toán
LY Điểm Lý
HOA Điểm Hóa
SINH Điểm Sinh
VAN Điểm Văn
DTB Điểm trung bình
XEPLOAI Xếp loại

Cách thứ nhất: Lập CSDL với 1 bảng 
duy nhất.

Cách thứ hai: Lập CSDL với 3 bảng. 

Cách thứ hai
khắc phục
được nhược
điểm của cách
thứ nhất.

4

Tuy nhiên, để có được thông tin
tổng hợp thì cần thông tin từ cả
3 bảng, nói cách khác cần có
liên kết giữa các bảng.

Bảng: HOCSINH

Tên trường Mô tả Ghi chú

MAHS Mã học sinh Khóa chính

MALOP Mã lớp học

HOHS Họ tên học sinh

TENHS Tên học sinh

PHAI Phái học sinh

NGAYSINH Ngày sinh học sinh

Bảng: LOPHOC
Tên trường Mô tả Ghi chú

MALOP Mã lớp học Khóa chính
GVCN Tên giáo viên chủ nhiệm.
PHONGHOC Phòng học

Bảng: DIEM
Tên trường Mô tả Ghi chú
HOCKY Học kỳ: 1, 2 Khóa chính
MAHS Mã học sinh Khóa chính
TOAN Điểm Toán
LY Điểm Lý
HOA Điểm Hóa
SINH Điểm Sinh
VAN Điểm Văn
DTB Điểm trung bình
XEPLOAI Xếp loại

Ví dụ: CSDL Quản lí điểm học sinh.

5

1> Một số khái niệm cơ bản

Khi xây dựng CSDL, liên kết
giữa các bảng được tạo ra
dùng để làm gì?

Tổng hợp dữ liệu từ
nhiều bảng.

6
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1> Một số khái niệm cơ bản

Trên thực tế, một CSDL có thể có nhiều bảng, do đó
sau khi đã xây dựng xong hai hay nhiều bảng, ta có
thể chỉ ra mối liên hệ giữa các bảng với nhau. Mục
đích của việc này là để Access biết phải kết nối các
bảng như thế nào khi kết xuất thông tin.

7

1> Một số khái niệm cơ bản

 Quan hệ một – một (one to one hoặc 1-1)

 Quan hệ một – nhiều (one to many hoặc 1 - ∞)

 Quan hệ nhiều – nhiều (many to many hoặc ∞ - ∞)

Quan hệ một – một: mỗi mẫu tin trong bảng A có tương ứng với
một mẫu tin trong bảng B và ngược lại mỗi mẫu tin trong bảng B có
tương ứng duy nhất một mẫu tin trong bảng A.

Quan hệ một – nhiều: một mẫu tin trong bảng A có thể có nhiều
mẫu tin tương ứng trong bảng B, nhưng ngược lại một mẫu tin trong
bảng B có duy nhất một mẫu tin tương ứng trong bảng A.

Quan hệ nhiều – nhiều: mỗi mẫu tin trong bảng A có thể có hoặc
không nhiều mẫu tin trong bảng B và ngược lại mỗi mẫu tin trong
bảng B có thể có hoặc không nhiều mẫu tin trong bảng A.

8

1> Một số khái niệm cơ bản

9

‒ Khi xây dựng CSDL, liên kết được tạo giữa các bảng cho
phép tổng hợp dữ liệu từ nhiều bảng.

‒ Quan hệ một – một (one to one hoặc 1-1): mỗi mẫu tin trong
bảng A có tương ứng với một mẫu tin trong bảng B và ngược
lại mỗi mẫu tin trong bảng B có tương ứng duy nhất một mẫu
tin trong bảng A.

‒ Quan hệ một – nhiều (one to many hoặc 1 - ∞): một mẫu tin
trong bảng A có thể có nhiều mẫu tin tương ứng trong bảng B,
nhưng ngược lại một mẫu tin trong bảng B có duy nhất một
mẫu tin tương ứng trong bảng A.

‒ Quan hệ nhiều – nhiều (many to many hoặc ∞ - ∞): mỗi
mẫu tin trong bảng A có thể có hoặc không nhiều mẫu tin
trong bảng B và ngược lại mỗi mẫu tin trong bảng B có thể có
hoặc không nhiều mẫu tin trong bảng A.

2> Kỹ thuật tạo mối liên kết giữa các bảng

‒ Bước 1: Chọn: Database Tools => Relationships.

10

2> Kỹ thuật tạo mối liên kết giữa các bảng

‒ Bước 2: Chọn các bảng cần tạo liên kết, click nút Add, rồi nút
Close (hoặc double click vào các bảng, rồi click nút Close).

11

2> Kỹ thuật tạo mối liên kết giữa các bảng

‒ Bước 3: Kéo trường cần tạo liên kết của Bảng 1 sang trường cần
tạo liên kết ở Bảng 2 rồi thả chuột (click Enforce Referential
Integrity), rồi click nút Create. Tương tự với các bảng còn lại.

12
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2> Kỹ thuật tạo mối liên kết giữa các bảng

‒ Bước 4: Chỉnh sửa hoặc xóa liên kết giữa các bảng

+ Nếu muốn xóa thì click phải ngay đường nối giữa 2 bảng,
chọn Delete (hoặc click ngay đường nối, nhấn phím Delete).

+ Nếu muốn chỉnh sửa thì click phải ngay đường nối giữa 2
bảng, chọn Edit Relationship… Chỉnh sửa rồi click OK.

+ Tương tự với các liên kết còn lại.

+ Nếu không có chỉnh sửa hoặc xóa thì có thể bỏ qua bước này.

13

2> Kỹ thuật tạo mối liên kết giữa các bảng

‒ Bước 5: Click nút Close để đóng cửa sổ Relationships lại. Sau
đó, chọn Yes để lưu lại các thay đổi (nếu có).

14

2> Kỹ thuật tạo mối liên kết giữa các bảng

‒ Bước 1: Chọn: Database Tools => Relationships.

‒ Bước 2: Chọn các bảng cần tạo liên kết, click nút Add, rồi nút
Close (hoặc double click vào các bảng, rồi click nút Close).

‒ Bước 3: Kéo trường cần tạo liên kết của Bảng 1 sang trường cần tạo
liên kết ở Bảng 2 rồi thả chuột (click  Enforce Referential
Integrity), rồi click nút Create. Tương tự với các bảng còn lại.

‒ Bước 4: Chỉnh sửa hoặc xóa liên kết giữa các bảng:

+ Nếu muốn xóa thì click phải ngay đường nối giữa 2 bảng, chọn
Delete (hoặc click ngay đường nối, nhấn phím Delete).

+ Nếu muốn chỉnh sửa thì click phải ngay đường nối giữa 2 bảng,
chọn Edit Relationship… Thực hiện chỉnh sửa rồi click OK.

+ Tương tự với các liên kết còn lại.

‒ Bước 5: Click nút Close để đóng cửa sổ Relationships lại. Sau đó,
chọn Yes để lưu lại các thay đổi (nếu có).

15 16
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SỞ GIÁO DỤC VÀ ĐÀO TẠO THÀNH PHỐ HỒ CHÍ MINH
Trường THPT TRẦN QUANG KHẢI

Tổ bộ môn: TIN HỌC

Bài dạy điện tử Tin học Lớp 12

GVHD: Vũ Trường

Lớp: 12A…… – Tiết: ……

Ngày: ……………… 

Ví dụ: CSDL QuanLi_HS (BTTH3 – SGK48)

YC1: Tìm kiếm HS theo Mã số (MaSo)?
YC2: Tìm kiếm những HS có ĐTB cao nhất lớp.

2

Ví dụ: CSDL QuanLi_HS (BTTH3 – SGK48)

 Trên thực tế khi quản lý học sinh ta thường có những yêu cầu khai thác
thông tin bằng cách đặt câu hỏi kiểu truy vấn (mẫu hỏi).

 Dạng thông thường nhất là mẫu hỏi chọn (Select Query). Khi thực hiện
mẫu hỏi, dữ liệu được kết xuất vào một bảng kết quả, nó hoạt động như
một bảng.

 Có thể chỉnh sửa, xóa, bổ sung dữ liệu vào các bảng thông qua bảng kết
quả (bảng mẫu hỏi).

3

1> Một số khái niệm

Mẫu hỏi là gì?

Mẫu hỏi là một loại đối
tượng của ACCESS dùng để
sắp xếp, tìm kiếm và kết xuất
dữ liệu từ một hoặc nhiều
bảng dựa vào liên kết giữa
các bảng.

Mẫu hỏi dùng để làm gì?

Mẫu hỏi thường được sử dụng để:
• Sắp xếp các bản ghi;
• Chọn các bản ghi thỏa mãn các

điều kiện cho trước;
• Chọn các trường cần thiết để hiển

thị;
• Thực hiện tính toán như: tính trung

bình cộng, tính tổng, đếm các bản
ghi, …;

• Tổng hợp và hiển thị thông tin từ
nhiều bảng hoặc mẫu hỏi khác.

a) Mẫu hỏi

4

1> Một số khái niệm

b) Biểu thức
Để thực hiện các tính toán và kiểm tra các
điều kiện, trong Access có công cụ để viết
các biểu thức (biểu thức số học, biểu thức
điều kiện và biểu thức lôgic).

Trong trường hợp nào thì
cần sử dụng biểu thức số
học, biểu thức điều kiện
và biểu thức lôgic?

• Biểu thức số học được sử dụng để mô tả các trường

tính toán trong mẫu hỏi.

• Biểu thức điều kiện và biểu thức lôgic được sử

dụng trong các trường hợp sau:

o Thiết lập bộ lọc cho bảng;

o Thiết lập điều kiện lọc để tạo mẫu hỏi.

5

1> Một số khái niệm

b) Biểu thức

Trong tính toán, chúng ta có
những loại phép toán nào?

Các kí hiệu phép toán thường dùng bao gồm:

• Phép toán số học: + , – , * , /

• Phép so sánh: <, >, <=, >=, =, <>

• Phép toán lôgic: AND, OR, NOT

6
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1> Một số khái niệm

b) Biểu thức

Chúng ta dùng các phép toán trên để tính
toán trên các toán hạng, vậy trong Access
các toán hạng là những đối tượng nào?

Các toán hạng trong tất cả các biểu thức có thể là:

• Tên trường (đóng vai trò các biến) được ghi trong dấu

ngoặc vuông.

• Hằng số.

• Hằng văn bản: được viết trong dấu nháy kép.

• Hàm (SUM, AVG, MAX, MIN, COUNT, …).

7

1> Một số khái niệm

c) Các hàm
Có thể tiến hành gộp nhóm các bản ghi theo
những điều kiện nào đó rồi thực hiện các phép
tính trên từng nhóm này. Access cung cấp các
hàm gộp nhóm thông dụng, trong đó có một số
hàm thường dùng như: SUM, AVG, MIN, MAX,
COUNT, …

Các hàm: SUM,
AVG, MIN, MAX,
COUNT dùng để
làm gì?

• SUM: Tính tổng các giá trị.

• AVG: Tính giá trị trung bình.

• MIN: Tìm giá trị nhỏ nhất.

• MAX: Tìm giá trị lớn nhất

• COUNT: Đếm số giá trị khác trống (Null).

Bốn hàm đầu tiên chỉ thực hiện trên các trường kiểu số.

8

‒ Mẫu hỏi là một loại đối tượng của ACCESS dùng để sắp xếp, tìm
kiếm và kết xuất dữ liệu từ một hoặc nhiều bảng dựa vào liên kết
giữa các bảng.

‒ Mẫu hỏi thường được sử dụng để:

+ Sắp xếp các bản ghi;

+ Chọn các bản ghi thỏa mãn các điều kiện cho trước;

+ Chọn các trường cần thiết để hiển thị;

+ Thực hiện tính toán như: tính trung bình cộng, tính tổng, đếm các
bản ghi, …;

+ Tổng hợp và hiển thị thông tin từ nhiều bảng hoặc mẫu hỏi khác.

1> Một số khái niệm

a) Mẫu hỏi

9

‒ Biểu thức số học được sử dụng để mô tả các trường tính toán trong mẫu hỏi.

‒ Biểu thức điều kiện và biểu thức lôgic được sử dụng trong các trường hợp
sau:

+ Thiết lập bộ lọc cho bảng;

+ Thiết lập điều kiện lọc để tạo mẫu hỏi.

‒ Các kí hiệu phép toán thường dùng bao gồm:

+ Phép toán số học: + , – , * , /

+ Phép so sánh: <, <=, >, >=, =, <>

+ Phép toán lôgic: AND, OR, NOT

‒ Các toán hạng trong tất cả các biểu thức có thể là:

+ Tên trường (đóng vai trò các biến) được ghi trong dấu ngoặc vuông.

+ Hằng số.

+ Hằng văn bản: được viết trong dấu nháy kép.

+ Hàm (SUM, AVG, MAX, MIN, COUNT, …).

1> Một số khái niệm

b) Biểu thức

10

‒ SUM: Tính tổng các giá trị.

‒ AVG: Tính giá trị trung bình.

‒ MIN: Tìm giá trị nhỏ nhất.

‒ MAX: Tìm giá trị lớn nhất

‒ COUNT: Đếm số giá trị khác trống (Null).

Bốn hàm đầu tiên chỉ thực hiện trên các trường kiểu số.

1> Một số khái niệm

c) Các hàm

11

2> Tạo mẫu hỏi

Để bắt đầu làm việc với mẫu hỏi, cần xuất
hiện trang mẫu hỏi bằng cách click nhãn
Queries trong bảng chọn đối tượng của cửa
sổ CSDL. Có thể tạo mẫu hỏi bằng cách
dùng thuật sĩ hay tự thiết kế.

Hãy nêu các bước
để tạo mẫu hỏi?

 Các bước để tạo mẫu hỏi:

• Chọn dữ liệu nguồn (các bảng và mẫu hỏi khác) cho mẫu hỏi;

• Chọn các trường từ dữ liệu nguồn để đưa vào mẫu hỏi;

• Khai báo các điều kiện cần đưa vào mẫu hỏi để lọc các bản

ghi;

• Chọn các trường dùng để sắp xếp các bản ghi trong mẫu hỏi;

• Tạo các trường tính toán từ các trường đã có;

• Đặt điều kiện gộp nhóm.
12
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2> Tạo mẫu hỏi

‒ Select Query: truy vấn chọn lựa trường hiển thị
từ một hoặc nhiều bảng, đồng thời có thể tạo ra
trường tính toán dữ liệu trong bảng.

‒ Make Table Query: truy vấn tạo bảng mới từ dữ
liệu đã có của các bảng khác.

‒ Append Query: truy vấn thêm mẫu tin mới hoặc
dữ liệu từ bảng khác vào cuối bảng được chọn.

13

2> Tạo mẫu hỏi

‒ Update Query: truy vấn cập nhật dữ liệu cho các
trường được chọn trong bảng.

‒ Crosstab Query: truy vấn chéo là thực hiện báo cáo có
tính chất thống kê, truy vấn sẽ thể hiện các mẫu tin
(dòng) trong bảng thành các cột (trường) khi hiển thị.

‒ Delete Query: truy vấn xóa mẫu tin trong bảng khi
thỏa điều kiện truy vấn.

‒ Pass – Throught Query: gửi các lệnh đến một
CSDL SQL như Microsoft SQL Server.

14

2> Tạo mẫu hỏi

‒ Cách 1: Click Create => Query Wizard.

‒ Cách 2: Click Create => Query Design.

Thường sử dụng cách 1 để tạo mẫu hỏi, sau đó
chỉnh sửa lại ở chế độ thiết kế (Design View).

15

‒ Bước 1: Chọn mẫu hỏi cần xem hay sửa.

‒ Bước 2: Click nút View, rồi chọn Design View.

2> Tạo mẫu hỏi

16

2> Tạo mẫu hỏi

17

2> Tạo mẫu hỏi

 Cửa sổ gồm hai phần:
• Phần trên (nguồn dữ liệu) hiển thị cấu trúc các bảng (và các

mẫu hỏi khác) có chứa các trường được chọn để dùng trong
mẫu hỏi này (muốn chọn trường nào thì double click vào
trường đó, tên trường và tên bảng sẽ xuất hiện ở phần dưới).

• Phần dưới là lưới QBE (Query By Example – mẫu hỏi theo ví
dụ), nơi mô tả mẫu hỏi. Mỗi cột thể hiển một trường sẽ được
sử dụng trong mẫu hỏi.

18
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2> Tạo mẫu hỏi

‒ Field: Khai báo tên các trường được chọn.
‒ Table: Tên bảng hoặc mẫu hỏi chứa trường tương ứng.
‒ Total: Chứa các hàm gộp nhóm: SUM, AVG, MIN,

MAX, COUNT, …
‒ Sort: Xác định (các) trường cần sắp xếp.
‒ Show: Xác định (các) trường xuất hiện trong mẫu hỏi.
‒ Criteria: Mô tả điều kiện để chọn các bản ghi đưa vào

mẫu hỏi. Các điều kiện được viết dưới dạng biểu thức
lôgic.

19

2> Tạo mẫu hỏi

‒ Các bước để tạo mẫu hỏi:

+ Chọn dữ liệu nguồn (các bảng và mẫu hỏi khác) cho mẫu hỏi;

+ Chọn các trường từ dữ liệu nguồn để đưa vào mẫu hỏi;

+ Khai báo các điều kiện cần đưa vào mẫu hỏi để lọc các bản ghi;

+ Chọn các trường dùng để sắp xếp các bản ghi trong mẫu hỏi;

+ Tạo các trường tính toán từ các trường đã có;

+ Đặt điều kiện gộp nhóm.

‒ Cách tạo mẫu hỏi:

+ Cách 1: Click Create => Query Wizard. (hay sử dụng)

+ Cách 2: Click Create => Query Design.

‒ Xem, sửa mẫu hỏi:

+ Bước 1: Chọn mẫu hỏi cần xem hay sửa.

+ Bước 2: Click nút View, rồi chọn Design View.

20
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SỞ GIÁO DỤC VÀ ĐÀO TẠO THÀNH PHỐ HỒ CHÍ MINH
Trường THPT TRẦN QUANG KHẢI

Tổ bộ môn: TIN HỌC

Bài dạy điện tử Tin học Lớp 12

GVHD: Vũ Trường

Lớp: 12A…… – Tiết: ……

Ngày: ………………

Ví dụ: CSDL QuanLi_HS (BTTH3 – SGK48)

Mặc dù có thể dùng bảng
để thực hiện nhập và sửa
dữ liệu trực tiếp nhưng đối
với người sử dụng nói
chung thì cách này không
được thuận tiện.

Để thuận tiện cho
việc nhập, sửa dữ liệu
trực tiếp chúng ta sử
dụng cách nào?

2

Nếu không muốn hiển thị tất cả
các trường có trong bảng thì xử
lý như thế nào?

Ví dụ: CSDL QuanLi_HS (BTTH3 – SGK48)

3

Trong trường hợp có nhiều bảng,
muốn hiển thị các trường từ
nhiều bảng khác nhau, chúng ta
xử lý như thế nào?

Ví dụ: CSDL QuanLi_HS (BTTH3 – SGK48)

4

Ví dụ: CSDL QuanLi_HS (BTTH3 – SGK48)

Để dễ dàng bố trí các trường theo cách hợp lí hơn,
ngoài ra cũng có thể không hiển thị tất cả các trường
và có thể hiển thị các trường từ nhiều bảng khác
nhau, ta sẽ sử dụng biểu mẫu.

5

1> Khái niệm biểu mẫu (Form)

Em hiểu thế nào
là biểu mẫu?

 Biểu mẫu là một loại đối tượng trong Access

được thiết kế để:

 Hiển thị dữ liệu trong bảng dưới dạng thuận

tiện để xem, nhập và sửa dữ liệu.

 Thực hiện các thao tác thông qua các nút

lệnh (do người thiết kế tạo ra).

 Biểu mẫu có thể được hiển thị như một trang dữ

liệu gồm các hàng và cột nhưng biểu mẫu còn có

thể hiển thị từng bản ghi.

6
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1> Khái niệm biểu mẫu (Form)

7

1> Khái niệm biểu mẫu (Form)

Form: Access tự tạo một Form từ một Table hoặc Query được
chọn trong khung Navigation Pane thì khi click nút Form,
Form mới sẽ tự động tạo ra với nguồn dữ liệu là Table hoặc
Query đó.

Form Design: Tạo ra một Form mới trống và hiển thị nó trong chế
độ Design View. Nếu một Table hoặc Query được chọn trong khung
Navigation Pane thì khi click nút Form Design, Form mới sẽ tự
động bị ràng buộc với nguồn dữ liệu là Table hoặc Query đó.

8

1> Khái niệm biểu mẫu (Form)

Blank Form: Tạo ra một Form trống, Form mới không bị
ràng buộc với một nguồn dữ liệu và nó sẽ mở ra trong chế độ
Layout View. Cần phải chỉ định một nguồn dữ liệu (bảng hoặc
truy vấn) và thiết kế Form bằng cách thêm các điều khiển từ
Field List.

Form Wizard: Access hỗ trợ các bước để thiết kế
Form đơn giản. Wizard sẽ yêu cầu các nguồn dữ
liệu, chọn các Field hiển thị trên Form và cho phép
chọn Layout cho Form mới.

9

1> Khái niệm biểu mẫu (Form)

Navigation Form: là một Form đặc biệt
hoàn toàn mới trong Access 2010, nhằm
thiết kế Form dạng Navigation User, cho
phép người dùng dễ dàng di chuyển giữa
các thành phần trong Form.

10

1> Khái niệm biểu mẫu (Form)

‒ Biểu mẫu là một loại đối tượng trong Access được thiết kế để:

+ Hiển thị dữ liệu trong bảng dưới dạng thuận tiện để xem,
nhập và sửa dữ liệu.

+ Thực hiện các thao tác thông qua các nút lệnh (do người thiết
kế tạo ra).

‒ Biểu mẫu có thể được hiển thị như một trang dữ liệu gồm các
hàng và cột nhưng biểu mẫu còn có thể hiển thị từng bản ghi.

11

2> Tạo biểu mẫu mới

‒ Ba cách hay sử dụng nhất là:

+ Cách 1: Click Create => Form (để tạo một Single Form).

+ Cách 2: Click Create => Form Design (để tự thiết kế biểu mẫu).

+ Cách 3: Click Create => Form Wizard (để dùng thuật sĩ).

‒ Chúng ta sẽ dùng cách 3 để tạo biểu mẫu.

12
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2> Tạo biểu mẫu mới

‒ Bước 1: Click Create => Form Wizard.
‒ Bước 2: Chọn bảng (hoặc mẫu hỏi) từ ô

Tables/Queries.
‒ Bước 3: Chọn các trường đưa vào biểu mẫu từ ô

Available Fields.

13

2> Tạo biểu mẫu mới

‒ Bước 4: Chọn cách bố trí (định dạng) biểu mẫu rồi click
Next.

‒ Columnar: Tiêu đề nằm ở cột bên trái, nội dung nằm ở cột bên phải,
xem kẻ nhau.

‒ Tabular: Tiêu đề nằm ở hàng đầu tiên, nội dung nằm ở các hàng phía
dưới.

‒ Datasheet: Tiêu đề nằm ở cột đầu tiên bên trái và hàng đầu tiên trên
cùng.

‒ Justifield: Tiêu đề nằm ở hàng trên, nội dung nằm ở hàng dưới, xem
kẻ nhau. 14

2> Tạo biểu mẫu mới

‒ Bước 5: Nhập tên cho biểu mẫu.

‒ Bước 6: Cuối cùng click Finish (kết thúc).

15

2> Tạo biểu mẫu mới

‒ Biểu mẫu mới tạo xong chưa giống
như yêu cầu, cần phải chỉnh sửa lại
cho đúng theo yêu cầu.

‒ Chuyển sang chế độ thiết kế để chỉnh
sửa lại biểu mẫu.

16

2> Tạo biểu mẫu mới

‒ Trong chế độ thiết kế của biểu mẫu, có thể:
+ Định dạng phông chữ cho các trường dữ liệu, các tiêu đề (sử

dụng phông chữ Tiếng Việt) và di chuyển các trường.
+ Thêm/bớt, thay đổi vị trí, kích thước các trường dữ liệu;
+ Tạo những nút lệnh (đóng biểu mẫu, chuyển đến bản ghi đầu,

bản ghi cuối,…) để người dùng thao tác với dữ liệu thuận
tiện hơn. 17

2> Tạo biểu mẫu mới

‒ Sau khi đã chỉnh sửa xong biểu mẫu, chuyển
sang chế độ Form View hoặc Layout View
để xem kết quả.

‒ Biểu mẫu sau khi đã chỉnh sửa xong theo
đúng yêu cầu.

18
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19

‒ Tạo biểu mẫu mới: 3 cách hay sử dụng nhất là:

+ Cách 1: Click Create => Form (để tạo một Single Form).

+ Cách 2: Click Create => Form Design (để tự thiết kế biểu mẫu).

+ Cách 3: Click Create => Form Wizard (để dùng thuật sĩ).

‒ Các bước tạo biểu mẫu bằng thuật sĩ:

+ Bước 1: Click Create => Form Wizard.

+ Bước 2: Chọn bảng (hoặc mẫu hỏi) từ ô Tables/Queries.

+ Bước 3: Chọn các trường đưa vào biểu mẫu từ ô Available Fields.

+ Bước 4: Chọn cách bố trí biểu mẫu rồi click Next.

+ Bước 5: Nhập tên cho biểu mẫu.

+ Bước 6: Cuối cùng click Finish (kết thúc).

‒ Trong chế độ thiết kế của biểu mẫu, có thể:

+ Định dạng phông chữ cho các trường dữ liệu, các tiêu đề (sử dụng phông chữ Tiếng Việt)
và di chuyển các trường.

+ Thêm/bớt, thay đổi vị trí, kích thước các trường dữ liệu;

+ Tạo những nút lệnh (đóng biểu mẫu, chuyển đến bản ghi đầu, bản ghi cuối,…) để người
dùng thao tác với dữ liệu thuận tiện hơn.

a) Tạo biểu mẫu mới

b) Chỉnh sửa biểu mẫu

2> Tạo biểu mẫu mới 3> Các chế độ làm việc với biểu mẫu

Chế độ biểu mẫu Chế độ thiết kế

20

3> Các chế độ làm việc với biểu mẫu

Chế độ biểu mẫu

‒ Biểu mẫu trong chế độ này
thường có giao diện thân
thiện và thường được sử
dụng để cập nhật dữ liệu.

‒ Để làm việc trong chế độ
biểu mẫu, ta thực hiện:
+ Cách 1: Double click lên tên

biểu mẫu cần mở.
+ Cách 2: Click phải lên tên

biểu mẫu cần mở rồi chọn
Open.

+ Cách 3: Chọn biểu mẫu rồi
click View => Form View
nếu đang ở chế độ thiết kế.

Chế độ thiết kế

‒ Trong chế độ thiết kế, ta có
thể thiết kế mới, xem hay
sửa đổi thiết kế cũ của biểu
mẫu.

‒ Để làm việc trong chế độ
thiết kế, ta thực hiện:
+ Cách 1: Click phải vào biểu

mẫu rồi chọn DesignView

+ Cách 2: Chọn biểu mẫu rồi
click View => Design View
nếu đang ở chế độ biểu mẫu.

21 22
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SỞ GIÁO DỤC VÀ ĐÀO TẠO THÀNH PHỐ HỒ CHÍ MINH
Trường THPT TRẦN QUANG KHẢI

Tổ bộ môn: TIN HỌC

Bài dạy điện tử Tin học Lớp 12

GVHD: Vũ Trường

Lớp: 12A…… – Tiết: ……

Ngày: ………………

Ví dụ: Bài toán thống kê

2

Sau mỗi kỳ thi, ta phải làm các thống kê về tình hình chất
lượng của kỳ thi (hoặc thống kê tình hình bán hàng của
một cửa hàng). Và công việc thống kê này, chúng ta phải
thực hiện và gặp thường xuyên trong cuộc sống.

Để thống kê số lượng học sinh
khá, giỏi, em làm như thế nào?

Ví dụ: Bài toán thống kê

3

Khi sử dụng các biểu mẫu, truy
vấn dữ liệu để giải quyết tình
huống trên, chúng ta có thể in ra
giấy để xem và lưu lại không?

Sau mỗi kỳ thi, ta phải làm các thống kê về tình hình chất
lượng của kỳ thi (hoặc thống kê tình hình bán hàng của
một cửa hàng). Và công việc thống kê này, chúng ta phải
thực hiện và gặp thường xuyên trong cuộc sống.

Ví dụ: Bài toán thống kê

4

Ngoài ra, còn có công cụ nào
khác để giải quyết tình huống
trên hay không?

Sau mỗi kỳ thi, ta phải làm các thống kê về tình hình chất
lượng của kỳ thi (hoặc thống kê tình hình bán hàng của
một cửa hàng). Và công việc thống kê này, chúng ta phải
thực hiện và gặp thường xuyên trong cuộc sống.

Ví dụ: Bài toán thống kê

5

Hình thức thích hợp nhất khi cần tổng hợp, trình bày và
in dữ liệu theo khuôn dạng là sử dụng báo cáo.

1> Khái niệm báo cáo

6

Vậy theo em, báo cáo là gì?

Báo cáo là hình thức thích hợp nhất khi
cần tổng hợp, trình bày và in dữ liệu theo
khuôn dạng.
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1> Khái niệm báo cáo

7

Theo em, báo cáo
như hình bên giúp
chúng ta những
điều gì?

‒ Thể hiện được sự so
sánh, tổng hợp thông tin
từ các nhóm dữ liệu.

‒ Trình bày nội dung văn
bản theo mẫu quy định.

1> Khái niệm báo cáo

8

‒ Để tạo một báo cáo, cần trả lời cho các câu hỏi sau:
+ Báo cáo được tạo ra để kết xuất thông tin gì?
+ Dữ liệu từ những bảng, mẫu hỏi nào sẽ được đưa vào

báo cáo?
+ Dữ liệu sẽ được nhóm thế nào?

‒ Để tạo nhanh các báo cáo ta cũng có thể dùng chức năng
Report Wizard.

Click Create => Report Wizard

1> Khái niệm báo cáo

‒ Báo cáo là hình thức thích hợp nhất khi cần tổng hợp, trình bày
và in dữ liệu theo khuôn dạng.

‒ Báo cáo thường được sử dụng để:

+ Thể hiện được sự so sánh, tổng hợp thông tin từ các nhóm dữ
liệu.

+ Trình bày nội dung văn bản theo mẫu quy định.

‒ Để tạo nhanh một báo cáo, thường thực hiện theo các bước
sau:

+ Bước 1: Dùng thuật sĩ tạo báo cáo (click Create => Report
Wizard).

+ Bước 2: Sửa đổi thiết kế báo cáo được tạo ra ở bước trên.

9

2> Dùng thuật sĩ để tạo báo cáo (SGK71, 72, 73, 74)

‒ Report: Access tự tạo một Report từ một Table hoặc Query được chọn trong
khung Navigation Pane thì khi click nút Report, Report mới sẽ tự động lấy
nguồn dữ liệu là Table hoặc Query đó.

‒ Report Design: tạo ra một Report mới trống và hiển thị nó trong chế độ
Design View. Nếu một Table hoặc Query được chọn trong khung Navigation
Pane thì khi click nút Report Design, Report mới sẽ tự động bị ràng buộc với
nguồn dữ liệu là Table hoặc Query đó.

‒ Blank Report: Tạo ra một Report trống, Report mới không bị ràng buộc với
một nguồn dữ liệu, và nó sẽ mở ra trong chế độ Layout View. Cần phải chỉ
định một nguồn dữ liệu (bảng hoặc truy vấn) và thiết kế Report bằng cách
thêm các điều khiển từ Field List.

‒ Report Wizard: Access hỗ trợ các bước để thiết kế Report đơn giản. Report
Wizard sẽ yêu cầu các nguồn dữ liệu, chọn các Field hiển thị trên Report và
cho phép chọn Layout cho Report mới.

‒ Labels: Access hỗ trợ các bước để thiết kế Report dạng nhãn. Mỗi một
Record là một nhãn.

10

2> Dùng thuật sĩ để tạo báo cáo (SGK71, 72, 73, 74)

11

‒ Bước 1: Click
Create => Report
Wizard.

‒ Bước 2: Trong hộp
thoại Report
Wizard, chọn thông
tin đưa vào báo cáo.

2> Dùng thuật sĩ để tạo báo cáo (SGK71, 72, 73, 74)

12

‒ Bước 3: Chọn trường để gộp nhóm trong báo cáo: trong ví dụ của
chúng ta, nháy đúp vào trường To để nhóm theo tổ; Nháy nút Next.
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2> Dùng thuật sĩ để tạo báo cáo (SGK71, 72, 73, 74)

13

‒ Bước 4: Chỉ ra các trường để sắp xếp thứ tự các bản ghi và các yêu
cầu thống kê theo nhóm:
+ Sắp xếp Ten theo bảng chữ cái.
+ Tính trung bình điểm Toán theo tổ.

2> Dùng thuật sĩ để tạo báo cáo (SGK71, 72, 73, 74)

14

‒ Bước 5: Chọn cách bố trí báo cáo và kiểu trình bày báo cáo
(có thể chấp nhận ngầm định). Nháy Next để tiếp tục.

‒ Bước 6: Trong màn hình cuối của thuật sĩ báo cáo: đặt tên cho
báo cáo. Nháy Finish để kết thúc.

2> Dùng thuật sĩ để tạo báo cáo (SGK71, 72, 73, 74)

15

Design View

Report View

2> Dùng thuật sĩ để tạo báo cáo (SGK71, 72, 73, 74)

16

2> Dùng thuật sĩ để tạo báo cáo (SGK71, 72, 73, 74)

‒ Bước 1: Click Create => Report Wizard.
‒ Bước 2: Trong hộp thoại Report Wizard, chọn thông tin đưa vào báo cáo:

+ Chọn bảng hoặc mẫu hỏi trong mục Tables/Queries.
+ Chọn lần lượt các trường cần thiết từ ô Available Fields sang ô Selected Fields bằng

cách nháy đúp vào tên trường: trong ví dụ này, chọn bảng HOC_SINH và chọn ba
trường Tên, To, Toan.

+ Nháy Next để sang bước tiếp theo.
‒ Bước 3: Chọn trường để gộp nhóm trong báo cáo: trong ví dụ của chúng ta, nháy đúp vào

trường To để nhóm theo tổ; Nháy nút Next.
‒ Bước 4: Chỉ ra các trường để sắp xếp thứ tự các bản ghi và các yêu cầu thống kê theo

nhóm.
o Sắp xếp Ten theo bảng chữ cái.
o Để tính trung bình điểm Toán theo tổ, nháy chuột vào Summary Options… rồi

đánh dấu vào Avg tương ứng với trường Toan. Nháy OK để quay lại màn hình
trước đó rồi nháy Next.

‒ Bước 5: Trong các bước tiếp theo, chọn cách bố trí báo cáo và kiểu trình bày báo cáo
(có thể chấp nhận ngầm định). Nháy Next để tiếp tục.

‒ Bước 6: Trong màn hình cuối của thuật sĩ báo cáo
+ Đặt tên cho báo cáo.
+ Chọn một trong hai tùy chọn Preview the report (xem báo cáo) hoặc Modify the

report’s design (sửa đổi thiết kế báo cáo).
+ Nháy Finish để kết thúc việc tạo báo cáo.

17 18
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SỞ GIÁO DỤC VÀ ĐÀO TẠO THÀNH PHỐ HỒ CHÍ MINH
Trường THPT TRẦN QUANG KHẢI

Tổ bộ môn: TIN HỌC

Bài dạy điện tử Tin học Lớp 12

GVHD: Vũ Trường

Lớp: 12A…… – Tiết: ……

Ngày: ………………

2

‒ Như đã biết ở các bài trước, có thể mô tả dữ liệu lưu
trữ trong CSDL bằng ngôn ngữ định nghĩa dữ liệu của
một hệ quản trị CSDL cụ thể.

‒ Tuy nhiên, để mô tả các yêu cầu dữ liệu của một tổ
chức sao cho dễ hiểu đối với người sử dụng khác nhau
cần có mô tả ở mức cao hơn (trừu tượng hơn).

Theo em, để mô tả ở mức cao
hơn (trừu tượng hơn) thì làm
như thế nào?

3

Theo em, để tiến hành xây dựng và khai
thác một hệ CSDL thường được tiến
hành qua mấy bước?

‒ Tiến hành qua 3 bước:
+ Tạo lập.
+ Cập nhật.
+ Khai thác.

4

Để có thể nghiên cứu và phát triển các
ứng dụng CSDL, cộng đồng những
người làm việc trong lĩnh vực CSDL cần
trao đổi với nhau về những yếu tố nào?

‒ Cấu trúc dữ liệu.
‒ Các thao tác, phép toán trên dữ liệu.
‒ Các ràng buộc dữ liệu.

5

‒ Tóm lại, để mô tả các yêu cầu dữ liệu của một tổ chức
sao cho dễ hiểu đối với người sử dụng khác nhau cần
có một mô hình dữ liệu quan hệ.

1> Mô hình dữ liệu quan hệ

6

Theo em, mô hình dữ liệu
quan hệ là gì?

Mô hình dữ liệu quan hệ (mô hình quan hệ): là
một tập các khái niệm dùng để mô tả cấu trúc dữ
liệu; các thao tác và phép toán trên dữ liệu; các
ràng buộc dữ liệu của một CSDL.
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1> Mô hình dữ liệu quan hệ

7

Theo em, mô hình dữ liệu
quan hệ do ai đề xuất và đề
xuất vào năm nào?

Mô hình quan hệ được E.F.Codd đề xuất năm
1970.

1> Mô hình dữ liệu quan hệ

8

Hãy kể tên các loại mô hình
dữ liệu mà em biết?

‒ Mô hình dữ liệu hướng đối tượng;
‒ Mô hình dữ liệu quan hệ;
‒ Mô hình dữ liệu phân cấp.

1> Mô hình dữ liệu quan hệ

9

‒ Theo mức mô tả chi tiết về CSDL, có thể phân chia
các mô hình thành 2 loại:
+ Các mô hình vật lí (còn được gọi là các mô hình

dữ liệu bậc thấp): cho biết dữ liệu được lưu trữ
như thế nào.

+ Các mô hình lôgic (còn được gọi là mô hình dữ
liệu bậc cao): cho mô tả CSDL ở mức khái niệm
và mức khung nhìn.

1> Mô hình dữ liệu quan hệ

10

Hãy trình hiểu biết của bản thân về các
yếu tố trong mô hình dữ liệu quan hệ?
‒ Về mặt cấu trúc.
‒ Về mặt thao tác trên dữ liệu.
‒ Về mặt các ràng buộc dữ liệu.

‒ Về mặt cấu trúc: dữ liệu được thể hiện trong các bảng.
Mỗi bảng bao gồm các hàng và các cột thể hiện thông tin
về một chủ thể.

‒ Về mặt thao tác trên dữ liệu: có thể cập nhật dữ liệu
như thêm, xóa hay sửa bản ghi trong một bảng.

‒ Về mặt các ràng buộc dữ liệu: dữ liệu trong một bảng
phải thỏa mãn một số ràng buộc, chẳng hạn, không được
có hai bộ nào trong một bảng giống nhau hoàn toàn.

1> Mô hình dữ liệu quan hệ

‒ Mô hình dữ liệu quan hệ (mô hình quan hệ) là một tập các khái niệm dùng
để mô tả:
+ Cấu trúc dữ liệu.
+ Các thao tác và phép toán trên dữ liệu.
+ Các ràng buộc dữ liệu.

‒ Các loại mô hình dữ liệu:
+ Mô hình dữ liệu hướng đối tượng.
+ Mô hình dữ liệu quan hệ.
+ Mô hình dữ liệu phân cấp.

‒ Trong mô hình quan hệ:
+ Về mặt cấu trúc: dữ liệu được thể hiện trong các bảng. Mỗi bảng bao

gồm các hàng và các cột thể hiện thông tin về một chủ thể.
+ Về mặt thao tác trên dữ liệu: có thể cập nhật dữ liệu như thêm, xóa hay

sửa bản ghi trong một bảng.
+ Về mặt các ràng buộc dữ liệu: dữ liệu trong một bảng phải thỏa mãn

một số ràng buộc, chẳng hạn, không được có hai bộ nào trong một bảng
giống nhau hoàn toàn.

11

2> Cơ sở dữ liệu quan hệ

12

Cơ sở dữ liệu là gì?

Một CSDL (Database) là một tập hợp các dữ liệu có
liên quan với nhau, chứa thông tin của một tổ chức nào
đó (như một trường học, một ngân hàng, một công ty,
một nhà máy, …), được lưu trữ trên các thiết bị nhớ
(như băng từ, đĩa từ, USB, …) để đáp ứng nhu cầu
khai thác thông tin của nhiều người dùng với nhiều
mục đích khác nhau.

a) Khái niệm
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2> Cơ sở dữ liệu quan hệ

13

Cơ sở dữ liệu quan hệ là gì?

 Cơ sở dữ liệu được xây dựng dựa trên mô hình dữ
liệu quan hệ gọi là cơ sở dữ liệu quan hệ.

a) Khái niệm

2> Cơ sở dữ liệu quan hệ

14

Hệ quản trị cơ sở dữ liệu là
gì?

Phần mềm cung cấp một môi trường thuận lợi và hiệu
quả để tạo lập, lưu trữ và khai thác thông tin của cơ sở
dữ liệu được gọi là hệ quản trị cơ sở dữ liệu (Database
Management System).

a) Khái niệm

2> Cơ sở dữ liệu quan hệ

15

Hệ quản trị cơ sở dữ liệu
quan hệ là gì?

 Hệ quản trị CSDL dùng để tạo lập, cập nhật và khai
thác CSDL quan hệ gọi là hệ QTCSDL quan hệ.

a) Khái niệm

2> Cơ sở dữ liệu quan hệ

16

Hãy trình bày các đặc trưng
chính của một quan hệ trong
hệ CSDL quan hệ?

‒ Mỗi quan hệ có một tên phân biệt với tên các quan
hệ khác.

‒ Các bộ là phân biệt và thứ tự các bộ không quan
trọng.

‒ Mỗi thuộc tính có một tên để phân biệt, thứ tự các
thuộc tính không quan trọng.

‒ Quan hệ không có thuộc tính đa trị hay phức hợp.

a) Khái niệm

2> Cơ sở dữ liệu quan hệ

17

a) Khái niệm

2> Cơ sở dữ liệu quan hệ

18

b) Ví dụ: (SGK83)
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19

2> Cơ sở dữ liệu quan hệ

c) Khóa và liên kết giữa các bảng

Khi các em gửi thư, các em
phải ghi đầy đủ địa chỉ của
người gửi và địa chỉ người
nhận. Như vậy địa chỉ của
người gửi và địa chỉ của người
nhận chính là các khóa.

Nếu các em không
ghi 1 trong 2 địa chỉ
thì điều gì sẽ xảy
ra?

Có thể không ghi địa chỉ người gửi, nhưng
bắt buộc phải ghi địa chỉ người nhận.

20

2> Cơ sở dữ liệu quan hệ

c) Khóa và liên kết giữa các bảng

‒ Vậy địa chỉ người nhận chính là khóa chính.
‒ Để đảm bảo sự nhất quán về dữ liệu, tránh trường hợp thông tin

về một đối tượng xuất hiện hơn một lần sau những lần cập
nhật. Do đó người ta sẽ chọn 1 khóa trong các khóa của bảng
làm khóa chính.

‒ Mục đích chính của việc xác định khóa là thiết lập sự liên kết
giữa các bảng. Điều đó cũng giải thích tại sao ta cần xác định
khóa sao cho nó bao gồm càng ít thuộc tính càng tốt.

2> Cơ sở dữ liệu quan hệ

‒ Cơ sở dữ liệu quan hệ là cơ sở dữ liệu được xây dựng dựa
trên mô hình dữ liệu quan hệ.

‒ Hệ QTCSDL quan hệ là hệ quản trị CSDL dùng để tạo lập,
cập nhật và khai thác CSDL quan hệ.

‒ Một quan hệ trong hệ CSDL quan hệ có các đặc trưng
chính sau:

+ Mỗi quan hệ có một tên phân biệt với tên các quan hệ khác;

+ Các bộ là phân biệt và thứ tự các bộ không quan trọng;

+ Mỗi thuộc tính có một tên để phân biệt, thứ tự các thuộc
tính không quan trọng;

+ Quan hệ không có thuộc tính đa trị hay phức hợp.

21

2> Cơ sở dữ liệu quan hệ

‒ Khóa: là một tập thuộc tính gồm một hay một số thuộc tính của
bảng có tính chất: không có hai hàng nào (trong một bảng) tương
ứng bằng nhau trên tất cả các thuộc tính.

‒ Khoá chính: một bảng có thể có nhiều khóa. Trong các khóa của
một bảng người ta thường chọn (chỉ định) một khóa làm khóa chính
(Primary Key).

+ Trong một hệ QTCSDL quan hệ, khi nhập dữ liệu cho một bảng,
dữ liệu tại các cột khóa chính không được để trống.

‒ Chú ý:

+ Mỗi bảng có ít nhất một khóa. Việc xác định khóa phụ thuộc vào
quan hệ lôgic của các dữ liệu chứ không phụ thuộc vào giá trị
các dữ liệu.

+ Nên chọn khóa chính là khóa có ít thuộc tính nhất.

‒ Liên kết: thực chất sự liên kết giữa các bảng là dựa trên thuộc tính
khóa.

22

23

Cám ơn
quý thầy/cô đã tham dự

Thân ái
chào các em
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SỞ GIÁO DỤC VÀ ĐÀO TẠO THÀNH PHỐ HỒ CHÍ MINH
Trường THPT TRẦN QUANG KHẢI

Tổ bộ môn: TIN HỌC

Bài dạy điện tử Tin học Lớp 12

GVHD: Vũ Trường

Lớp: 12A…… – Tiết: ……

Ngày: ………………

2

Hãy nêu các
bước chính để
tạo cơ sở dữ
liệu?

Tạo lập, cập nhật và
khai thác dữ liệu.

Trong soạn thảo văn
bản mà các em đã học,
để tạo một danh sách
học sinh em phải thực
hiện như thế nào?

Tạo cấu trúc bảng và nhập
dữ liệu.

3

Muốn tạo CSDL theo mô hình
quan hệ thì thực hiện như thế
nào?

Việc đầu tiên để tạo một CSDL quan hệ là tạo
ra một hay nhiều bảng.

1> Tạo lập cơ sở dữ liệu

‒ Tạo bảng: để tạo một bảng ta cần phải xác định và khai báo cấu
trúc bảng, bao gồm:

+ Đặt tên các trường;

+ Chỉ định kiểu dữ liệu cho mỗi trường.

+ Khai báo kích thước của trường.

‒ Chọn khóa chính cho bảng bằng cách để hệ QTCSDL tự động
chọn hoặc ta xác định khóa thích hợp trong các khóa của bảng.

‒ Đặt tên bảng và lưu cấu trúc bảng.

‒ Tạo liên kết giữa các bảng bằng cách xác định các trường
chung trong các bảng.

4

2> Cập nhật dữ liệu

5

‒ Bước đầu tiên để tạo lập một CSDL quan hệ là
tạo ra một hay nhiều bảng. Để thực hiện điều
đó, cần phải xác định và khai báo cấu trúc
bảng.

‒ Trong cơ sở dữ liệu quan hệ cũng tương tự
như vậy, sau khi các em đã tạo xong cấu trúc
cho bảng ta phải cập nhật dữ liệu cho bảng.

2> Cập nhật dữ liệu

‒ Sau khi cấu trúc bảng đã được tạo, có thể nhập dữ liệu cho
bảng.

‒ Dữ liệu nhập vào có thể được chỉnh sửa, thêm, xóa:

+ Thêm bản ghi bằng cách bổ sung một hoặc một vài bộ dữ
liệu vào bảng.

+ Chỉnh sửa dữ liệu là việc thay đổi các giá trị của một vài
thuộc tính của một bộ mà không phải thay đổi toàn bộ giá trị
các thuộc tính còn lại của bộ đó.

+ Xóa bản ghi là việc xóa một hoặc một số bộ của bảng.

6
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2> Cập nhật dữ liệu

7

Phần lớn các hệ QTCSDL cho phép tạo ra biểu mẫu
nhập dữ liệu (H.76. SGK90) để làm cho công việc
nhập dữ liệu trở nên dễ dàng hơn, nhanh hơn và hạn
chế bớt khả năng nhầm lẫn.

3> Khai thác cơ sở dữ liệu

8

Trong quá trình cập nhật dữ liệu không tránh khỏi những
sai sót, do đó Access cũng cung cấp cho chúng ta những
chức năng để xử lý những tình huống đó:
‒ Sắp xếp các bản ghi.
‒ Truy vấn CSDL.
‒ Xem dữ liệu.
‒ Kết xuất báo cáo.

3> Khai thác cơ sở dữ liệu

‒ Sắp xếp các bản ghi
+ Một trong những việc mà một hệ QTCSDL thường phải thực hiện là khả

năng tổ chức hoặc cung cấp phương tiện truy cập các bản ghi theo một trình
tự nào đó.

+ Ta có thể hiển thị trên màn hình hay in ra các bản ghi theo trình tự này. Các
bản ghi có thể được sắp xếp theo nội dung của một hay nhiều trường.

‒ Truy vấn CSDL
+ Truy vấn là một phát biểu thể hiện yêu cầu của người sử dụng. Truy vấn mô

tả các dữ liệu và thiết đặt các tiêu chí để hệ quản trị CSDL có thể thu thập dữ
liệu thích hợp.

+ Nói một cách khác, đó là một dạng lọc, có khả năng thu thập thông tin từ
nhiều bảng trong một CSDL quan hệ.

‒ Để phục vụ được việc truy vấn CSDL, thông thường các hệ quản trị CSDL cho
phép nhập các biểu thức hay các tiêu chí nhằm các mục đích sau:
+ Định vị các bản ghi;
+ Thiết lập liên kết giữa các bảng để kết xuất thông tin;
+ Liệt kê một tập con các bản ghi hoặc tập con các trường;
+ Thực hiện các phép toán;
+ Thực hiện các thao tác quản lí dữ liệu khác.

9

3> Khai thác cơ sở dữ liệu

‒ Xem dữ liệu: thông thường các hệ QTCSDL cung cấp nhiều
cách xem dữ liệu:

+ Có thể xem toàn bộ bảng.

+ Có thể dùng công cụ lọc dữ liệu để xem một tập con các bản
ghi hoặc một số trường trong một bảng.

+ Các hệ quản trị CSDL quan hệ quen thuộc cũng cho phép tạo
ra các biểu mẫu để xem các bản ghi.

‒ Kết xuất báo cáo

+ Thông tin trong một báo cáo được thu thập bằng cách tập
hợp dữ liệu theo các tiêu chí do người sử dụng đặt ra.

+ Báo cáo thường được in ra hay hiển thị trên màn hình theo
khuôn mẫu định sẵn. Cũng như các biểu mẫu, các báo cáo có
thể xây dựng dựa trên các truy vấn.

10

11

Cám ơn
quý thầy/cô đã tham dự

Thân ái
chào các em

 38 / 42         



SỞ GIÁO DỤC VÀ ĐÀO TẠO THÀNH PHỐ HỒ CHÍ MINH
Trường THPT TRẦN QUANG KHẢI

Tổ bộ môn: TIN HỌC

Bài dạy điện tử Tin học Lớp 12

GVHD: Vũ Trường

Lớp: 12A…… – Tiết: ……

Ngày: ………………

2

Ngày nay, trong xã hội tin học hóa nhiều hoạt
động đều diễn ra trên mạng có qui mô toàn thế
giới. Do đó vấn đề bảo mật thông tin được đặt
lên hàng đầu.

Vấn đề bảo mật

3

Theo em, để bảo mật thông tin
cho cơ sở dữ liệu, chúng ta
thực hiện như thế nào?

Cung cấp cho người dùng Username và
Password để đăng nhập vào CSDL.

Vấn đề bảo mật

4

Khi thiết kế CSDL, chúng ta
thiết kế các bảng như thế nào
để bảo mật thông tin?

Thiết kế một bảng riêng chứa Username và
Password để truy cập vào CSDL.

Vấn đề bảo mật

5

Làm cách nào để mỗi
Username và Password là duy
nhất?

Tạo khóa chính cho bảng chứa Username và
Password.

Vấn đề bảo mật

6

Nhất thiết phải có các cơ chế bảo vệ, phân quyền
truy nhập thì mới có thể đưa CSDL vào khai thác
thực tế.

Vấn đề bảo mật

 39 / 42         



7

Theo em, bảo mật là gì?

Bảo mật là vấn đề chung cho cả hệ CSDL và những hệ
thống khác.

Vấn đề bảo mật

8

Theo em, bảo mật trong hệ
CSDL là gì?

‒ Ngăn chặn các truy cập không được phép;
‒ Hạn chế tối đa các sai sót của người dùng;
‒ Đảm bảo thông tin không bị mất hoặc bị thay đổi

ngoài ý muốn;
‒ Không tiết lộ nội dung dữ liệu cũng như chương

trình xử lí.

Vấn đề bảo mật

Vấn đề bảo mật

‒ Bảo mật là vấn đề chung cho cả hệ CSDL và những hệ thống
khác.

‒ Bảo mật trong hệ CSDL là:

+ Ngăn chặn các truy cập không được phép.

+ Hạn chế tối đa các sai sót của người dùng.

+ Đảm bảo thông tin không bị mất hoặc bị thay đổi ngoài ý
muốn.

+ Không tiết lộ nội dung dữ liệu cũng như chương trình xử lí.

9 10

Các giải pháp chủ yếu cho bảo
mật hệ thống gồm có những
gì?

‒ Chính sách và ý thức.
‒ Phân quyền truy cập và nhận dạng người dùng.
‒ Mã hóa thông tin và nén dữ liệu.
‒ Lưu biên bản.

Vấn đề bảo mật

1> Chính sách và ý thức

11

‒ Việc bảo mật có thể thực hiện bằng các giải pháp kỹ thuật cả
phần cứng lẫn phần mềm.

‒ Tuy nhiên, việc bảo mật phụ thuộc vào rất nhiều các chủ
trương, chính sách của chủ sở hữu thông tin và ý thức của
người dùng.

1> Chính sách và ý thức

‒ Ở cấp quốc gia, hiệu quả bảo mật phụ thuộc vào sự quan tâm
của Chính phủ trong việc ban hành các chủ trương, chính sách,
điều luật quy định của Nhà nước về bảo mật.

‒ Người phân tích, thiết kế và người quản trị CSDL phải có các
giải pháp tốt về phần cứng và phần mềm thích hợp để bảo mật
thông tin, bảo vệ hệ thống.

‒ Người dùng cần có ý thức coi thông tin là một tài nguyên quan
trọng, cần có trách nhiệm cao, thực hiện tốt các quy trình, quy
phạm do người quản trị hệ thống yêu cầu, tự giác thực hiện các
điều khoản do pháp luật quy định.

12
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2> Phân quyền truy cập và nhận dạng người dùng

13

‒ Ví dụ: Một số hệ quản lí học tập và giảng dạy của nhà
trường cho phép mọi phụ huynh HS truy cập để biết kết quả
học tập của con em mình.
+ Mỗi phụ huynh chỉ có quyền xem điểm của con em

mình hoặc của khối con em mình học. Đây là quyền truy
cập hạn chế nhất (mức thấp nhất).

+ Các thầy cô giáo trong trường có quyền truy cập cao
hơn: xem kết quả và mọi thông tin khác của bất kì HS
nào trong trường.

+ Người quản lí học tập có quyền nhập điểm, cập nhật
các thông tin khác trong CSDL.

2> Phân quyền truy cập và nhận dạng người dùng

14

Bảng phân quyền truy cập
Mã HS Các điểm số Các thông tin khác

Khối 10 Đ Đ K

Khối 11 Đ Đ K

Khối 12 Đ Đ K

Giáo viên Đ Đ Đ

Người quản trị ĐSBX ĐSBX ĐSBX

Đ: đọc – S: sửa – B: bổ sung – X: xóa

Theo em, điều gì sẽ xảy ra
khi không có bảng phân
quyền?

Khi không có
bản phân quyền,
các em vào xem
điểm đồng thời
cũng có thể sửa
điểm của mình.

15

Người quản trị hệ CSDL cần
cung cấp những gì cho người
dùng?

‒ Bảng phân quyền truy cập cho hệ QTCSDL.
‒ Phương tiện cho người dùng để hệ QTCSDL

nhận biết đúng được họ.

2> Phân quyền truy cập và nhận dạng người dùng

16

Người dùng muốn truy cập
vào hệ thống cần khai báo gì?

‒ Tên người dùng.
‒ Mật khẩu.

2> Phân quyền truy cập và nhận dạng người dùng

2> Phân quyền truy cập và nhận dạng người dùng

17

‒ Khi phân quyền người truy cập CSDL điều quan trọng là hệ
quản trị CSDL phải nhận dạng được người dùng, tức là phải
xác minh được người truy cập thực sự đúng là người đã
được phân quyền.

‒ Đảm bảo được điều đó nói chung rất khó khăn. Một trong
những giải pháp thường được dùng đó là sử dụng mật khẩu.

‒ Ngoài ra, người ta còn dùng phương pháp nhận diện dấu
vân tay, nhận dạng con người, …

2> Phân quyền truy cập và nhận dạng người dùng

‒ Người quản trị hệ CSDL cần cung cấp:
+ Bảng phân quyền truy cập cho hệ QTCSDL;
+ Phương tiện cho người dùng để hệ QTCSDL nhận biết đúng

được họ.
‒ Người dùng muốn truy cập vào hệ thống cần khai báo:

+ Tên người dùng.
+ Mật khẩu.

‒ Dựa vào hai thông tin này, hệ QTCSDL xác minh để cho phép hoặc
từ chối quyền truy cập CSDL.

‒ Chú ý:
+ Đối với nhóm người có quyền truy cập cao thì cơ chế nhận dạng

có thể phức tạp hơn.
+ Hệ QTCSDL cung cấp cho người dùng cách thay đổi mật khẩu.

Do đó người dùng nên sử dụng khả năng này để định kì thay đổi
mật khẩu, tăng cường khả năng bảo vệ mật khẩu.

18
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2> Phân quyền truy cập và nhận dạng người dùng

19

‒ Ngoài việc bảo mật bằng phân quyền cũng như việc người
truy cập chấp hành đúng chủ trương chính sách thì còn một
giải pháp nữa để bảo mật thông tin đó là mã hóa thông tin.

3> Mã hóa thông tin và nén dữ liệu

20

‒ Trong chương trình lớp 10, chúng ta đã đề cập đến mã hóa
thông tin theo nguyên tắc vòng tròn thay mỗi kí tự bằng một
kí tự khác.

‒ Còn có cách mã hóa khác là mã hóa độ dài loạt, khi chúng
ta mã hóa theo phương pháp này, ngoài việc giảm dung
lượng còn tăng tính bảo mật thông tin.

‒ Các giải pháp mã hóa khác: Caesar, Vigenere, Rail Fence
Cipher, RSA, DES, 3DES, SHA, …

3> Mã hóa thông tin và nén dữ liệu

‒ Mã hóa độ dài loạt là một cách nén dữ liệu khi trong tệp dữ
liệu có các kí tự được lặp lại liên tiếp.

+ Ví dụ: Từ AAAAAAABBBBBBCCC

oKết quả: mã hóa thành 7A6B3C

‒ Mục đích:

+ Làm giảm dung lượng lưu trữ.

+ Tăng cường tính bảo mật của dữ liệu.

‒ Chú ý: Các bản sao dữ liệu thường được mã hóa và nén bằng
các chương trình riêng.

21

4> Lưu biên bản

22

‒ Biên bản hệ thống hỗ trợ đáng kể cho việc khôi phục hệ
thống khi có sự cố kĩ thuật, đồng thời cung cấp thông tin
cho phép đánh giá mức độ quan tâm của người dùng đối với
hệ thống nói chung và đối với từng thành phần của hệ thống
nói riêng.

‒ Dựa trên biên bản này, người ta có thể phát hiện những truy
cập không bình thường (ví dụ ai đó quá thường xuyên quan
tâm đến một số loại dữ liệu nào đó vào một số thời điểm
nhất định), từ đó có những biện pháp phòng ngừa thích hợp.

4> Lưu biên bản

‒ Ngoài các giải pháp nêu trên, người ta còn tổ chức lưu biên bản
hệ thống. Thông thường, biên bản hệ thống cho biết:

+ Số lần truy cập vào hệ thống, vào từng thành phần của hệ
thống, vào từng yêu cầu tra cứu,…

+ Thông tin về một số lần cập nhật cuối cùng: nội dung cập
nhật, người thực hiện, thời điểm cập nhật, …

23 24

Cám ơn
quý thầy/cô đã tham dự

Thân ái
chào các em
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